Won't idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Won't idle

Metalcloak: Celebrate Freedom with Free ShippingFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-08-2015, 05:10 AM   #1
mallard3914
Registered User
1978 CJ7 
 
Join Date: May 2014
Location: Huntland, Tn
Posts: 80
Won't idle

1978 CJ7 stock 304. Jeep was been running great. Thursday, I left my lights on and drained the battery. I had to jump start it. Since the jump start it will not idle. The choke isn't working either it seems. It will stay running for about 10 sec but rpm is only 500. Prior to Thurs it was 750. Any idea what may be going on?

mallard3914 is online now   Reply With Quote Quick reply to this message
Unread 06-08-2015, 05:28 AM   #2
matt1980
Member
 
matt1980's Avatar
1980 CJ5 
 
Join Date: Dec 2013
Location: Harker Heights, TX
Posts: 122
Assume was running great prior to dead battery, I would try to isolate the problem, sounds like you are leaning towards choke, I believe the choke will not work until the engine builds oil pressure, you may try bypassing and run direct power to choke, if it works at least you know that the choke was in fact the problem and the choke works when powered, then turn your attention to wiring that is suppose to power choke or maybe the switch on the block, at least none of this will cost you anything.
matt1980 is offline   Reply With Quote Quick reply to this message
Unread 06-08-2015, 05:53 AM   #3
mallard3914
Registered User
1978 CJ7 
 
Join Date: May 2014
Location: Huntland, Tn
Posts: 80
Quote:
Originally Posted by matt1980 View Post
Assume was running great prior to dead battery, I would try to isolate the problem, sounds like you are leaning towards choke, I believe the choke will not work until the engine builds oil pressure, you may try bypassing and run direct power to choke, if it works at least you know that the choke was in fact the problem and the choke works when powered, then turn your attention to wiring that is suppose to power choke or maybe the switch on the block, at least none of this will cost you anything.
Yes Matt is was running fine till the battery drain. I just wonder if I somehow pulled the power wire off the choke when I was hooking up the jumper cables. Thanks for the insight.
mallard3914 is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.