why won't my heater work? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > why won't my heater work?

Huge Soft top SaleAdvance Adapters SYE KitsCurrie Antirock, Currectlync & Lift Kits on Sale!

Reply
Unread 09-22-2013, 10:48 PM   #1
cwig12
Registered User
1983 CJ7 
 
Join Date: Jun 2013
Location: Chesterfield, Missouri
Posts: 316
why won't my heater work?

I just had a brand new heater core put in but when I turn the fan on and set the pull knobs to vent heat in it just blows cold air. And if I pull far enough it just closes my vents instead of blowing hot air let alone any air. Is there some trick to it that I'm missing?

This is a 1983 CJ7 Laredo, stock.

__________________
Creative-X 3D Printing and Design

Place orders through: creativex3dprinting@gmail.com
cwig12 is online now   Reply With Quote Quick reply to this message
Unread 09-23-2013, 05:17 AM   #2
lucdog
Web Wheeler
 
lucdog's Avatar
1980 CJ5 
 
Join Date: Jul 2006
Location: , Il.
Posts: 8,073
Control cables ( not really a cable, it's a solid wire in a sheath) not hooked up correctly . Or broken, possibly the "cable" inside the box itself.
__________________
1957 WILLYS pickup, needs work.
1973 J 4000,
1978 CJ7 DD.
1979 CJ7 360, TH400/Quadratrac trail Jeep.
1979 J20
1980 CJ5 trail Jeep.
1983 CJ7 pretty weekend and sometimes to work Driver in the summer, My first rebuild, if the Q-trac and 5 are broke, this one is the one to take. its just as capable as the other 2, except nice paint.
1984 Grand Wagoneer, 1 ton axles, great 360/727, and a big a$& tree fell on it .
1989 YJ the CJ to YJ conversion.
2005 TJ Rubicon.
2011 Grand Cherokee Laredo 4x4, Mrs. LUCDOG's DD.
Lots of parts not for sale, i'm a hoarder.
lucdog is offline   Reply With Quote Quick reply to this message
Unread 09-23-2013, 07:26 AM   #3
walkerhoundvm
Registered User
1981 CJ8 
 
Join Date: Apr 2010
Location: The Little Apple, KS
Posts: 3,090
Mine tends to blow hot air no matter how I have my cables positioned. I'd be worried your heater core is junk.

Are the supply and return hoses getting hot? If both of those are hot, then I'd be looking at why the heat isn't hitting your feet - like a cable problem or something.
walkerhoundvm is offline   Reply With Quote Quick reply to this message
Unread 09-23-2013, 12:40 PM   #4
hp_lovecraft
Registered User
1981 CJ5 
 
Join Date: Sep 2009
Location: Maine
Posts: 1,019
When you pull the "temp" cable, you should be able to see the other end attached to he heater box. Its all the way on the left/bottom side. It actuates a door instead the box that directs the air through, or around the heater box.

If that is working properly, and the heater hoses are hot, then it might be your "vent" knob? It needs to be in the "middle" setting, otherwise the fresh air does not blow over the heater core. Was the vent cable attached? It is a huge pain in the butt to get that cable back on that lots of people forget about it, or its incorrectly adjusted
hp_lovecraft is offline   Reply With Quote Quick reply to this message
Unread 09-23-2013, 01:12 PM   #5
cwig12
Registered User
1983 CJ7 
 
Join Date: Jun 2013
Location: Chesterfield, Missouri
Posts: 316
Thanks, I'll have to take a look. I know when I looked down there the first time my duct wasn't even connected to the vent that directs the air to my feet. So I guess it's safe to assume they forgot to connect a few things.
__________________
Creative-X 3D Printing and Design

Place orders through: creativex3dprinting@gmail.com
cwig12 is online now   Reply With Quote Quick reply to this message
Unread 09-24-2013, 08:50 AM   #6
cwig12
Registered User
1983 CJ7 
 
Join Date: Jun 2013
Location: Chesterfield, Missouri
Posts: 316
I found the problem. Whoever connected my cables up switched the defrost and temp cables.
__________________
Creative-X 3D Printing and Design

Place orders through: creativex3dprinting@gmail.com
cwig12 is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.