Weak Leaf Springs? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Weak Leaf Springs?

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.comAlloy usa heavy duty ball joint kits

Reply
Unread 05-04-2010, 09:15 AM   #1
jufor24
Registered User
1976 CJ5 
 
Join Date: Dec 2009
Location: South Carolina
Posts: 7
Weak Leaf Springs?

I've got a 76 CJ5 that intermittently wont go when shifting from 1st to 2nd and 2nd to 3rd. I put it in gear, let out clutch and the engine revs but jeep doesnt move. It typically does this when trying to pull out into traffic quickly - in other words shifting and gassing quickly. I had a mechanic look at it and he said it is because of weak leaf springs and that all vehicles will do this if leaf springs are weak and you're jamming thru the gears. I'm not a mechanic but this makes no sense to me - it seems like more of a drive train issue. Has anyone else had this issue or have knowledge of leaf springs?

jufor24 is offline   Reply With Quote Quick reply to this message
Unread 05-04-2010, 09:31 AM   #2
bigirons79CJ5
Registered User
1979 CJ5 
 
Join Date: Apr 2009
Location: Mobile, Al
Posts: 117
Weak leaf springs!! That's a new one to me and makes me chuckle. Sounds like your clutch is slipping.
__________________
79 CJ5 4" Skyjacker
35" Dunlop MT's, 9000lb Warn
304 built with Edelbrock cam,valve springs,timing set,intake,Holley truck avenger carb, DUI ignition, fenderwell headers w/Supertrapps, Twin Sticked D20
FOR MORE PICTURES, CHECK OUT MY PHOTOBUCKET
http://s999.photobucket.com/albums/af118/bigirons79cj5/
bigirons79CJ5 is offline   Reply With Quote Quick reply to this message
Unread 05-04-2010, 10:31 AM   #3
jufor24
Registered User
1976 CJ5 
 
Join Date: Dec 2009
Location: South Carolina
Posts: 7
I thought that too - and replaced the clutch. However that didnt fix it....
jufor24 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.