T-4 Trans. Problem. - JeepForum.com

LinkBack Thread Tools
post #1 of 6 Old 09-08-2009, 06:40 PM Thread Starter
Registered User
1986 CJ7 
Join Date: Sep 2006
Location: Louisiana
Posts: 144
T-4 Trans. Problem.

Ok guys ...has anyone here ever changed the ..(Hope i got this right) the front bearing on the input shaft? I have a T-4 tranny and i think this bearing is bad. Never messed with this stuff with a transmission before.

86 cj-7 laredo, 31 10.50 BFG A/T, holes and rust.
"CJ's arent for the weak"---Hunt_Nevada
tarheel is offline  
Sponsored Links
post #2 of 6 Old 09-08-2009, 09:50 PM
Registered User
1978 CJ7 
Join Date: Nov 2006
Posts: 299
I have a t-4 never changed the front bearing in it. Why do you think yours is bad?
Mike78cj7 is offline  
post #3 of 6 Old 09-08-2009, 10:09 PM
Registered User
1985 CJ7 
Join Date: Aug 2009
Location: Indiana
Posts: 81
I did mine a few months ago, first time I ever cracked open a tranny. I pulled the drivetrain to do it, I figured I might as well replace the seals, fluids and clutch at the time. Wasn't too difficult. I had to source some bearing spacers out of Texas (I'm in Indiana), to get the proper endplay. I used one, I think the rest are still in my shed.
The T4 is really basic, it's just remembering how it goes back together.
Here's the factory manual-
I had trouble with the shifter base, page 7 shows how it disassembles. Only specialty tool I needed was a punch, to remove a roll pin. I actually used a nail, with the point ground flat. My punches never came back home.
trillobite is offline  
post #4 of 6 Old 09-08-2009, 10:12 PM
Registered User
1985 CJ7 
Join Date: Aug 2009
Location: Indiana
Posts: 81
Originally Posted by Mike78cj7 View Post
I have a t-4 never changed the front bearing in it. Why do you think yours is bad?
Probably noise. The front bearing in mine made the noise, when the fluid went low. The rear seal (between T4 and D300) had probably been slowly dripping for years, and I didn't notice it. I think it's because it's the last to get lubrication. It sounded like 3rd gear had exploded, it made such a racket.
Tranny shop quoted me $4,000 to rebuild, so I figured I had nothing to lose if I tried to fix it.
Couldn't find any burnt bearing surfaces or chipped gears, so I re-shimmed the input bearing, bolted it back up, and no noise. I think I just got really, really lucky.
trillobite is offline  
post #5 of 6 Old 09-08-2009, 10:15 PM
1982 CJ7 
Join Date: Dec 2008
Location: Rayne, LA
Posts: 277
Dude 4,000 is ridiculous...did you mean 400 because that would be reasonable. 4000? Those guys are on the pipe big time!!
jeepmaster03 is offline  
post #6 of 6 Old 09-08-2009, 10:23 PM
Registered User
1985 CJ7 
Join Date: Aug 2009
Location: Indiana
Posts: 81
Definitely told me $4,000. He's supposed to be a T4/5 specialist. He gave me a funny look when I asked if a AMC T5 would swap in, and told me they weren't compatible.
It was really hard to keep a straight face as I left, and I thanked him for his time.
If it was $400, I'd have paid him to do the work. But heck, for $4,000, I'll do it myself, and change a bunch of other parts along the way.
Now, if only those new hubs would get off backorder. Come on, Quadratec! Hook me up!
trillobite is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.0 t-176 trans lastcj Jeep CJ Forum 1 03-17-2009 08:29 AM
T-5 trans help gary68 Jeep CJ Forum 1 04-23-2007 08:27 AM
problem with T90 3 speed trans killas1mo Jeep CJ Forum 7 06-03-2006 11:08 AM
what trans? TheCherokeeKidd Jeep CJ Forum 2 05-19-2005 03:33 PM
Trans mojotomred Jeep CJ Forum 0 10-01-2004 07:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome