Surge in idle, when in PARK, after a long drive. -

LinkBack Thread Tools
post #1 of 2 Old 07-15-2013, 12:41 PM Thread Starter
Registered User
1980 CJ7 
Join Date: Mar 2011
Location: chandler
Posts: 339
Surge in idle, when in PARK, after a long drive.

Howell fuel injection, 258

After a long drive(20 miles), come home and put the jeep in park and the tach stays at about 1200 RPMs. Even if you hit the gas pedal, it has a hard time to get back down to 650ish RPMs. Eventually goes but noticed the jeep has done this multiple times.

Any ideas or has someone had this before?


offroadz is offline  
Sponsored Links
post #2 of 2 Old 07-15-2013, 01:06 PM
Registered User
1981 CJ8 
Join Date: Apr 2010
Location: The Little Apple
Posts: 3,408
I've had it before, don't know what to make of it. As long as she calms down for the emissions people, I haven't worried about it too much. I'd be interested to see what this thread turns up, though.
walkerhoundvm is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome