Starting problems - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 07-11-2003, 06:06 PM Thread Starter
possum398
Registered User
 
Join Date: May 2003
Location: Mississippi
Posts: 22
Starting problems

I am having problems starting my Jeep when it is warm. If it is up to running temp it has trouble starting. The engine that is in it is about two weeks old. It is a 304 with edelbrock performer intake and carb. The only other problems I am having is an exhaust leak. Once it starts everything is fine.

possum398 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-13-2003, 05:13 PM
johnnyamc
Registered User
 
Join Date: Mar 2002
Location: Tennessee
Posts: 19
I just rebuilt a 304 for my cj7 with a edelbrock performer intake and 600 cfm edelbrock carb. I had starting problems but I just had too high a compression ratio for the battery answer bigger battery. But are you getting fuel or is it not turning over or wanting to die or what? Good luck

1978 Jeep CJ-7 T-400 Q-Trac New 304 edelbrock intake and 4 barrel carb, comp cam, .060 over, dogleg heads and it DOES have some power.Forget swapping in a 350 chevy. Always AMC.
johnnyamc is offline  
post #3 of 3 Old 07-13-2003, 10:34 PM Thread Starter
possum398
Registered User
 
Join Date: May 2003
Location: Mississippi
Posts: 22
It is getting fuel and turning over. It just takes a while when it is hot. After I have ran it an hour or so.
possum398 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
still have starting problems HELP HELP jcooley7 Jeep CJ Forum 21 06-13-2008 05:21 PM
starting problems jcooley7 Jeep CJ Forum 6 06-07-2008 07:48 PM
225 V6 starting problems jrm72 Jeep CJ Forum 4 05-18-2008 07:52 PM
amc 304 starting problems mrloadie Jeep CJ Forum 3 08-13-2006 07:21 PM
Starting problems… toynutz Jeep CJ Forum 8 02-03-2006 01:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome