Sputter & Stall - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 05-30-2004, 10:45 AM Thread Starter
Registered User
nozzleram's Avatar
Join Date: May 2004
Location: North Central Indiana
Posts: 139
Sputter & Stall

I am stumped with a nagging problem. I have a 77 CJ7 with the original 304/TH 400 and a D300 added to replace Quadratrac. The previous owner replaced the carb with an electric choke Motorcraft. My problem started a few weeks ago when taking off from a cold start. I would get about ľ mile down the road and the engine would sputter. As time progressed it would sputter and then stall. It would take several minutes before it would re-start. When I would open the butterfly I would see smoke coming up out of the carb. I tried allowing more warm up time but this doesnít seem to make any difference. Weather has been all types wet, dry, cool, and warm. After a couple of weeks trying to trouble shoot this problem it got worse. It started to sputter after hitting bumps on the road. This progressed to sputtering and then stalling after hitting bumps on the road. Same re-start problem. This may not be an issue but the connections for the EGR off the exhaust manifold are open. They rusted off and are just sitting there exposed. I plan to replace original manifold with a pair of headers next month. Now, to make matters even more confusing, the darn thing runs great when this problem isnít acting out. Gas mileage is the same crappy 10 MPG, power and torque is unchanged. Any thoughts on where to look or what to do?

nozzleram is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
weber 34/34 sputter kc8emr Jeep CJ Forum 0 07-01-2009 07:04 PM
cj idles fine but won't drive w/o sputter, stall jeffzcj5 Jeep CJ Forum 4 05-07-2007 10:59 PM
304 Sputter sketchystreet Jeep CJ Forum 12 01-29-2007 09:18 PM
Jeep Cuts Out W/No Sputter MDJeeper Jeep CJ Forum 9 11-11-2005 06:05 AM
Sputter and die... RARECJ8 Jeep CJ Forum 8 09-27-2005 03:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome