Speedo, Fuel Gauge and Temp gauge not working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 07-07-2008, 12:29 PM Thread Starter
KYCJ7
Registered User
1980 CJ7 
 
Join Date: Jul 2008
Location: KY
Posts: 20
Speedo, Fuel Gauge and Temp gauge not working

Now that I've got my CJ running right its on to the smaller problems. First of which being is the speedo, fuel gauge and temp gauge do not work. They are all on the same cluster I don't know if that matters. I'm lost when it comes to gauges I would appreciate any help you can give. I don't mind the speedo as much as the other two because I don't want to over heat it and I sure don't want to run out of gas out in the middle of no where.


KYCJ7
KYCJ7 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-07-2008, 12:41 PM
LGreevesCJ7
Registered User
1977 CJ7 
 
Join Date: May 2008
Location: Oologah
Posts: 525
Check the speedometer cable and the gear in the transfer. check that the fuel tank ground wire is connected to a chasis ground and all wires are connected to back of cluster.
LGreevesCJ7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
TEMP GAUGE, FUEL GAUGE, AND SPEEDO HELP PlEASE cgi2099 Jeep CJ Forum 8 11-03-2009 05:49 PM
Temp Gauge not working (atypical caps on back of speedo) cb_cooke Jeep CJ Forum 6 02-21-2009 02:46 PM
fuel and temp gauge not working stonewallmp5 Jeep CJ Forum 5 04-13-2007 08:12 AM
Temp and Fuel Gauge not working bamakrw Jeep CJ Forum 97 05-17-2005 11:30 AM
temp and fuel gauge not working? aufderheide Jeep CJ Forum 7 02-22-2004 11:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome