Shuts off randomly - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Shuts off randomly

Year End Clearance Sale! Save 20%Savvy FREE SHIPPING!Artec Holiday Sale!

Reply
Unread 01-08-2010, 10:48 AM   #1
jeeperscrepers
Registered User
1979 CJ7 
 
Join Date: Dec 2008
Location: South Carolina
Posts: 71
Shuts off randomly

Back last February 2009, I had some work done on my CJ7 at a locally Jeep Mechanic...place is in Pickens area. Ever since then I have had electrical issues with grounding, brake lights not working, turn signals, etc. Even jeep cutting off while driving was a random issue after that (they pulled steering column to change upper bearing) and now jeep is cutting off to the point it is driving me crazy!!! It just cuts off and the fuel pump is still pumping and all electrical stuff functions. Just recently noticed sometimes if I turn the ign. switch back (not to lock pos but just a bit) it will sometimes regain its "fire" and continue running. Any thoughts on this issue and possilbe things to check as well as how best to check them.

Side note...I recently had to replace heater switch and straight wire brake switch due to no power to brake switch from harness. Now voltage has dropped considerably, could be bad ground on heater switch??? or belt to ALT is slipping because of chirping and squealing...???

jeeperscrepers is offline   Reply With Quote Quick reply to this message
Unread 01-08-2010, 03:25 PM   #2
RetiredSERE
Member
 
RetiredSERE's Avatar
1980 CJ7 
 
Join Date: Dec 2007
Location: Chesapeake, VA
Posts: 449
I would first go and check all your connections under the dash, to include the connector that goes to the ignition. If they had to pull the steering column to replace the bearing, they might have stretched on of your connections (loosened them).

Just a thought.
__________________
Shoot, Move, Communicate

Admit to Nothing, Deny Everything, Make Counter Accusations...

I Feel Like a Monkey F***ing a Football..
RetiredSERE is offline   Reply With Quote Quick reply to this message
Unread 01-08-2010, 03:29 PM   #3
John Strenk
Moderator
 
John Strenk's Avatar
1976 CJ5 
 
Join Date: Feb 2005
Location: Shalersville Ohio
Posts: 13,248
They may have miss adjusted your ignition switch. There are two different circuits in the switch so while some electrical stuff will run the engine may not be getting power properly.
John Strenk is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.