RuggedRidge Tie Rod Taper/Bind issue ... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 09-26-2013, 05:22 PM Thread Starter
ChiefRocka
Registered User
1994 XJ Cherokee 
 
Join Date: Sep 2013
Location: hollister
Posts: 58
RuggedRidge Tie Rod Taper/Bind issue ...

Hey Guys !!

After an inspection of my front axle, I went ahead and tore into it for a ball joint replacement.

All that went smooth.

Tie rods were next.

Instead of going stock, I found RuggedRidge's kit which included new tierods, and heavier DOM tubing.

I went to install the cross tube, and noticed the tie rods buried themselves pretty deep ...

When I went to install the drag link, (knuckle first) it was so deep, that it would not pivot up to the pitman arm.

I mean, there is no movement.

We called them the next morning and got no where. They claim "just install it, it will work"

They claim its a 1ton equivalent end, but the taper seems too small.

This Jeep still had its factory parts, so I know the knuckle tapers are not worn.

Anyone else have this problem, or lack of customer support ???

Now, I have to return the product and go back to more expensive, stock stuff.

ChiefRocka is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-26-2013, 07:17 PM
Blakescj7
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2013
Location: Tulsa
Posts: 439
Pictures?
Blakescj7 is offline  
post #3 of 4 Old 09-27-2013, 03:48 AM
skizriz
Registered User
1978 CJ7 
 
Join Date: Jun 2011
Location: Scottdale
Posts: 5,021
I recently put a RR tie rod/drag Link kit in mine with no issues.

Sent from my HTC One SV using JeepForum
skizriz is offline  
post #4 of 4 Old 09-27-2013, 06:36 AM
walkerhoundvm
Registered User
1981 CJ8 
 
Join Date: Apr 2010
Location: The Little Apple
Posts: 3,408
I put the base model rugged ridge tie rod kit on my CJ last summer with no issues.

Note: their end grease is just temporary stuff, you'll need to put your own grease in there when you install.
walkerhoundvm is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome