Rear Main Seal - Wrong part from Quadratec? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 06-08-2015, 09:32 PM Thread Starter
AndrewUVM
Registered User
1986 CJ7 
 
Join Date: Feb 2012
Location: Bethel
Posts: 52
Rear Main Seal - Wrong part from Quadratec?

Ordered a rear main seal from Quadratec beginning of last week which turned out to be back ordered. They ended up shipping it out on Friday which arrived today but I think the part is incorrect from their supplier.

Supposed to be a replacement for my 86 CJ7 with a 4.2L, the seal has two identical parts whereas the picture on the website shows two unique pieces to the seal.

What I received:


Can anyone confirm that this is incorrect, or am I supposed to modify one of these to cut off the tabs?

Thanks

AndrewUVM is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-09-2015, 06:10 AM
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert
Posts: 18,012
Should look like this.

Matt
Attached Images
 
Matt1981CJ7 is offline  
post #3 of 7 Old 06-09-2015, 07:54 AM
WindKnot
Registered User
1977 CJ7 
 
Join Date: Mar 2011
Posts: 3,936
Yeah, they screwed up. Have you tried locally? That's a fairly common part.

I'd rather be lost on the trails than found at home!

Phoenix Rising- A Flame Off Restoration?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WindKnot is offline  
 
post #4 of 7 Old 06-09-2015, 10:45 AM
holliewood61
Web Wheeler
 
holliewood61's Avatar
1981 CJ7 
 
Join Date: May 2013
Location: Peterstown
Posts: 1,568
Hers the Napa part number if it helps

FPG BS40612

08 WK bone stock
00 WJ daily driver
99 TJ mostly stock 97 TJ cheap jeep
81 CJ7 very little stock
60 CJ5 tore down
holliewood61 is offline  
post #5 of 7 Old 06-09-2015, 11:25 AM
CSP
Registered User
 
Join Date: Aug 2002
Location: Colorado
Posts: 15,974
x2, go to your local auto parts store. There's no need to mail order a part like that.
CSP is offline  
post #6 of 7 Old 06-09-2015, 01:09 PM Thread Starter
AndrewUVM
Registered User
1986 CJ7 
 
Join Date: Feb 2012
Location: Bethel
Posts: 52
It was mail-ordered as part of a larger order of parts.
AndrewUVM is offline  
post #7 of 7 Old 06-10-2015, 09:40 PM Thread Starter
AndrewUVM
Registered User
1986 CJ7 
 
Join Date: Feb 2012
Location: Bethel
Posts: 52
Looks like quadratec got a bad batch of parts from Crown. Got a replacement in the mail today and it is the same as the first.
AndrewUVM is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome