post #1 of Old 01-30-2014, 02:15 PM Thread Starter
DGRobles
Registered User
1986 CJ7 
 
Join Date: Apr 2005
Location: Mexico City
Posts: 244
RC front leaf defective?

Please your help...


I have a RoughCountry leaf suspension (2.5) but I am having issues. My driver side tire is behind for about 3/4 of an inch and is causing drag on that side that I need to correct with the steering wheel... it don't stay straight and physically you can see that tire a little back or behind compared to the passenger side.

Comparing the distance from the rear mounting base of the leaf to the axle tube my driver side is shorter and the suspension has less than 500o mi on it and basically street...

Do you know what could be the possible reason?... Defective leaf?


Thanks


Diego Robles / XE1XZQ
DGRobles is offline  
post #2 of Old 01-30-2014, 02:46 PM
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert - Palmdale, Ca. U.S.A.
Posts: 5,882
Ck the springs center bolt.
LG

Have'n you along, is like loose'n 2 good men
LumpyGrits is offline  
post #3 of Old 01-30-2014, 09:29 PM Thread Starter
DGRobles
Registered User
1986 CJ7 
 
Join Date: Apr 2005
Location: Mexico City
Posts: 244
Same dimensions on the center bolts... however, driver side leaf has more lift than passenger's one, by one inch and I think that's the problem...

Diego Robles / XE1XZQ
DGRobles is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome