random stalling - JeepForum.com
 
LinkBack Thread Tools
post #1 of 10 Old 04-11-2013, 02:49 PM Thread Starter
rutheford
Registered User
1979 CJ7 
 
Join Date: Oct 2009
Location: torrance california
Posts: 2
random stalling

i have a 1979 jeep cj7 manual tranny with an amc 304 with 15000 miles since it was rebuilt. its been intermittently stalling mostly under load and i cant figure it out. i have a complete new exhaust. rebuilt mc2100 about a month ago. new fuel pump fuel filter dist cap and rotor timed at 5 btdc iv got new plug wires. now i have a bad cat smell but the problem was ocurring before the new cat. maybe float bowl? any input would be much appreciated thanks

Attached Thumbnails
318374_10150310316626009_198438242_n.jpg  
rutheford is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-28-2013, 06:15 PM
pman
Web Wheeler
 
pman's Avatar
1988 YJ Wrangler 
 
Join Date: Aug 2005
Location: Charleston, SC
Posts: 1,488
Completely cutting out like you turned off the ignition? Or slow dying?

88 Wrangler Laredo 258-999-NP231
81/76 CJ5 304-t150-Spicer 20
82 Wagoneer 360-727-NP208
82 CJ8 Scrambler 258-t5-Dana 300
http://www.jeepforum.com/forum/f8/cj...-lulu-1350563/
http://www.jeepforum.com/forum/f8/ca...epair-2709825/
pman is offline  
post #3 of 10 Old 04-28-2013, 09:27 PM
Trapshooter
Registered User
1986 CJ7 
 
Join Date: Mar 2007
Location: Jacksonville, Oregon
Posts: 2,309
Disconnect the cat and see if the problem still occurs.

'86 CJ7, 258, Carter BBD, Nutter'ed, TeamRush'ed, T-18, Twin Sticked Dana 300, D30 Frt-Pwr Lok L/S-4.10, AMC 20 Rear-Mosers-Detroit Locker-4.10, 2.5 BDS Lift, 1" Body Lift, 33" Wild Country M/Ts, Black Spoke wheels

'45 CJ2A, L134 Go Devil, T-90 Tranny, Warn O/D, T-18 T-Case, Dana 25 Frt, Dana 41 Rear, 531st CJ made

My 401 build: http://www.jeepforum.com/forum/f8/tr...build-1338277/
Trapshooter is offline  
post #4 of 10 Old 06-19-2013, 12:14 PM
rch316
Registered User
1978 CJ7 
 
Join Date: Jun 2013
Location: Osterville
Posts: 2
Did you figure out the problem

Hi Trapshooter were you able to figure out what was wrong with your Jeep? My CJ7 is randomly stalling on me while driving down the road. It has done it twice in the past week. It will start back up within 30 seconds after stalling. Any advice would be great. Thank you!
rch316 is offline  
post #5 of 10 Old 06-19-2013, 01:17 PM
Newbjeep
Registered User
1972 CJ5 
 
Join Date: Feb 2013
Location: Arlington
Posts: 1,169
I had the same problem all the sudden it started stalling every ten min turned out I had a grease rag in my gas tank that would plug my sending unit
Newbjeep is offline  
post #6 of 10 Old 06-24-2013, 08:06 AM
rch316
Registered User
1978 CJ7 
 
Join Date: Jun 2013
Location: Osterville
Posts: 2
Quote:
Originally Posted by pman View Post
Completely cutting out like you turned off the ignition? Or slow dying?
Yes it is completely cutting out like turning off the ignition while driving.
rch316 is offline  
post #7 of 10 Old 06-24-2013, 09:50 AM
84bluecj
Registered User
1984 CJ7 
 
Join Date: Oct 2011
Posts: 11
Try checking your grounds motor to body and motor to frame... An loose connection can imitate and act like your describing
84bluecj is offline  
post #8 of 10 Old 06-24-2013, 08:02 PM
pman
Web Wheeler
 
pman's Avatar
1988 YJ Wrangler 
 
Join Date: Aug 2005
Location: Charleston, SC
Posts: 1,488
May possibly be your ignition module going on the fritz IF its very sudden. Try using the search function on the CJ forum; Bagus Jeep has written some thorough instructions on troubleshooting the ignition components.

Over the years, I've had three things that have caused the sudden shutoff as you describe:
-ignition module
-ignition switch
-pickup coil

88 Wrangler Laredo 258-999-NP231
81/76 CJ5 304-t150-Spicer 20
82 Wagoneer 360-727-NP208
82 CJ8 Scrambler 258-t5-Dana 300
http://www.jeepforum.com/forum/f8/cj...-lulu-1350563/
http://www.jeepforum.com/forum/f8/ca...epair-2709825/
pman is offline  
post #9 of 10 Old 06-25-2013, 12:27 PM
jimark
Registered User
1979 CJ7 
 
Join Date: Jun 2011
Location: Clarksville
Posts: 29
I had the same issue with my 79, I checked the coil it would shoot spark up but when it got warm it would just die then start up 2 min later. This went on for a month, then changed coil and issue goes away.
jimark is offline  
post #10 of 10 Old 06-25-2013, 07:09 PM
skizriz
Registered User
1978 CJ7 
 
Join Date: Jun 2011
Location: Scottdale
Posts: 4,938
My random stalling problem turned out to be the cap for the coil. The red wire was down to a single strand of wire where the terminal was crimped on.
It would randomly shut off. Hit the key and it would start right back up again.Took me months to figure out the problem, which I noticed by sheer luck.
A bit of solder and it's as good as new.

78 CJ7.. 258.. TH400/Dana18.. SOA/stock YJ springs.. 35" General Grabbers.. Waggy 44s.. 4.88 gears...Spartan/Lockright...Fiberglass front to rear
skizriz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome