Radiator Hose Leak - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Radiator Hose Leak

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line~Artec JK 1 TON SWAP~Advance Adapters SYE Kits

Reply
Unread 06-29-2013, 12:29 PM   #1
mikeb11
Registered User
1984 CJ7 
 
Join Date: Jun 2013
Location: Covington, LA
Posts: 4
Radiator Hose Leak

Can anyone tell me why my radiator hose is so close to the steering column causing it to rub every time I turn and eventually cutting the lower hose. I have an 84 cj7 with an inline 6 motor. This is my first jeep and I have ordered a new 4" suspension lift hoping this will help. it currently has a 3" shackle lift installed. Any information is greatly appreciated.

mikeb11 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2013, 12:43 PM   #2
walkerhoundvm
Registered User
1981 CJ8 
 
Join Date: Apr 2010
Location: The Little Apple, KS
Posts: 3,090
Lose the shackle kit. I have to wonder if that's throwing the geometry off of the engine/frame/radiator interface and making your hose come in contact with your steering column. And a 4" suspension lift seems like an expensive fix for what might amount to just adjusting your radiator hose. Are you sure it's the correct lower hose?
walkerhoundvm is offline   Reply With Quote Quick reply to this message
Unread 06-29-2013, 05:06 PM   #3
adman02
Registered User
1979 CJ7 
 
Join Date: Jul 2008
Location: Durham, NC
Posts: 294
This JUST happened to me. I just finished body work and paint. Had to get a new-to-me grille and when I put everything back together the steering shaft ripped a hole in the lower radiator hose.

Solution: redrill the mounting holes on your radiator 1/2 in to 5/8 in below the existing ones (hat tip to lumpygrits).

Not sure why the new grill holds the radiator lower, but it did. I never had that issue with the old grille.
adman02 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.