Quick question and short story. Stalling 304 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 04-20-2013, 07:35 PM Thread Starter
Heyjack
Registered User
1977 CJ5 
 
Join Date: Jan 2013
Posts: 50
Quick question and short story. Stalling 304

I sold my 81 cj5 to relieve some debt, regret it but, I am fortunate to still be left with a 77 cj5 304 3spd. So I am trying to get it going good and having a little trouble. It starts, runs and don't sound to bad, but won't stay running, as in drive around pasture awhile and it stops, won't start back until it sets a while then fires right up. It previously had new carb, spark plugs, fuel pump, fuel filter and was doing this still. So I added an hei distributor today in hopes that would some how magically fix it. It did not. I have heard of vapor locks and such so I poured a little gas down the carb today when it was in its wont start period and still nothing. I had prior to the hei install checked fire during the won't start period and it did have spark. Any thoughts or suggestions?

Heyjack is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-20-2013, 08:06 PM
walkerhoundvm
Registered User
1981 CJ8 
 
Join Date: Apr 2010
Location: The Little Apple
Posts: 3,408
Ignition control module.

For vapor lock - one easy check is to remove the gas cap so that there's ambient air pressure in the tank.
walkerhoundvm is offline  
post #3 of 4 Old 04-20-2013, 09:03 PM Thread Starter
Heyjack
Registered User
1977 CJ5 
 
Join Date: Jan 2013
Posts: 50
Thanks walkerhoundvm, does the gm style hei I put in eliminate the ignition control module or is it still somehow involved? The distributor was the hei kit from 4wd.
Heyjack is offline  
post #4 of 4 Old 04-20-2013, 09:38 PM
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings
Posts: 152
Quote:
Originally Posted by Heyjack
Thanks walkerhoundvm, does the gm style hei I put in eliminate the ignition control module or is it still somehow involved? The distributor was the hei kit from 4wd.
Yes it does Jack.

Sent from my iPhone using JeepForum
firemanjim7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome