problems with 258 overheat, etc - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > problems with 258 overheat, etc

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 07-16-2003, 11:47 PM   #1
edge1
Registered User
 
Join Date: Jun 2003
Posts: 68
problems with 258 overheat, etc

I just bought this jeep and took it to my mechanic today. new thermostadt, radiator flushed and like new, no leaks worth noting. the engine can idle all day, but overheats quick as soon as the rpms come up. he thinks it may be a cracked block. if it is, should I just order a long block (like from rebuilt-jeep-engines.com) and have someone put it in? What else is involved?I don't know if the engine in it now is original or not. I have a 86 CJ7 with the 258. Please Help!!

edge1 is offline   Reply With Quote Quick reply to this message
Unread 07-17-2003, 01:33 AM   #2
only in a jeep cj
Registered User
1986 CJ7 
 
Join Date: Jun 2001
Location: Mobile, Alabama
Posts: 4,233
Cracked block, huh... what else is the engine doing....like loss of power? weird noises? etc. Run a compression check across all 6 and check the carb. Too lean of a mix can make an engine run hotter...so I have been told by several mechanics. You can also remove the radiator cap when the engine is cold, start/run it and as the thermostate opens, observe the water flow rate. Also check the timming. and advance.
__________________
Ed

1975 CJ-6 304 T15 Dana20 30/44 3.73
1983 CJ-8 258 T5 300 30/44 3.31 Looking for full or half hardtop buy or trade
1986 CJ-7 Laredo 4.6 stroker T5 300 30/44 3.31
1986 TJ-7 Trail Jeep project in the works
2003 Inca Gold TJ Rubicon
only in a jeep cj is offline   Reply With Quote Quick reply to this message
Unread 07-17-2003, 09:05 AM   #3
edge1
Registered User
 
Join Date: Jun 2003
Posts: 68
no loss of power, no noises, good compression, wate is flowing. not sure about timing or advance.
edge1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.