JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Jeep CJ Forum (http://www.jeepforum.com/forum/f8/)
-   -   Power steering pump bad? or Bearing? (http://www.jeepforum.com/forum/f8/power-steering-pump-bad-bearing-1542093/)

DropeTine99 06-27-2013 01:13 PM

Power steering pump bad? or Bearing?
 
I've got a 81 CJ7. i recently had a cracked power steering hose so i took off the power steering belt and drove it home. Then the next day i started the jeep and it was squealing really bad. I thought once i put the power steering belt back on it'd even out the tension being pulled from the fan belt (think i tightened it to much) so i fixed the hose problem then put the power steering belt back on and it was still squealing. loosened the fan belt and the squealing stopped. BUT then when i turn the wheel it squeals and slows down the power steering pulley to a crawl. So when I think i either burned up the power steering pump or ruined the bearing on it or the bearing on the fan belt (because it was squealing even with the power steering belt off)

agear 06-27-2013 01:53 PM

You obviously put fluid back in there.........

pman 06-27-2013 02:15 PM

Did you bleed the pump? You might have air in it. The old ham can PS pumps are actually very easy to rebuild if you'd prefer not to buy a new one.

DropeTine99 06-27-2013 02:21 PM

Lol yeah i filled it up with fluid :2thumbsup: and no i didnt. i just kept filling it when it'd run out. and ill rebuild one if i can

LumpyGrits 06-27-2013 02:54 PM

Take all the belts off.
See how easily and smooth the alt, W'pump and P/S pump turn by hand.
LG


The time now is 04:03 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.