Performance Cam and Vac Advance - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 07-10-2013, 09:58 PM Thread Starter
xnodesirex
Registered User
1978 CJ7 
 
Join Date: Aug 2012
Location: cincinnati
Posts: 57
Performance Cam and Vac Advance

As I rebuild my engine, I've got the old girl idling well at around 8* BTDC @ 1000 RPM (15" Vac). This is apparently the norm for having an Edelbrock performance cam the PO installed.

I had to install a reman distributor from autozone, and it still idles fine, but plugging in the vac advance causes the engine to go haywire. I confirmed it wasn't a vacuum leak, and the vac advance canister holds a signal perfectly well.

Is there something that I'm really missing? Does the upgraded cam mess with timing to a significant degree? Is it possible my centrifugal advance is already in at 1000 degrees, so it doesn't have much further to go, thus causing the vac advance to cause stutters/backfires/and bogs?

xnodesirex is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-10-2013, 11:00 PM
swatson454
Registered User
1983 CJ7 
 
Join Date: May 2009
Location: Texas Hill Country
Posts: 6,514
Are you running an HEI, by chance?

Live in a way that those who know you but don't know God will come to know God because they know you.
swatson454 is offline  
post #3 of 3 Old 07-12-2013, 12:59 PM Thread Starter
xnodesirex
Registered User
1978 CJ7 
 
Join Date: Aug 2012
Location: cincinnati
Posts: 57
MSD Ignition, Upgrade Cap and Rotor (Team Rush'd), 8.5 wires, etc.

Stock dizzy though (reman'd).
xnodesirex is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome