Oil Pressure for my 304 pegs the guage 80+ psi ?? - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 17 Old 10-09-2013, 11:08 AM
Rollbar
Registered User
1984 CJ8 
 
Join Date: Aug 2005
Location: Florida
Posts: 2,526
Found the answer



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<----Click


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<---- Click
Rollbar is offline  
Sponsored Links
Advertisement
 
post #17 of 17 Old 10-09-2013, 11:23 AM
WSS
Web Wheeler
 
WSS's Avatar
1972 CJ5 
 
Join Date: Oct 2012
Location: Chino
Posts: 2,664
Quote:
Originally Posted by gmakra View Post
Seems to me that there is a lot of chatter brands of gauges but what if the relief valve on the oil pump is jammed closed and the gauge is reading correctly?
I would put any old gauge on the engine and verify the PSI and then come up with a plan of action.
You could be right but the general consensus is it is a gauge, it appears the oe gauge is not a good one.
WSS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome