New aluminum valve cover doesn't fit?? - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 19 Old 06-09-2013, 03:52 PM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
New aluminum valve cover doesn't fit??

I have a clearwater 4.0 conversion head and the red aluminum valve cover from Crown doesn't fit? Plus I cant tell why, at first I thought it was the rocker bridges hitting but its not. all the bolt holes look dead on it just wont sit down completely onto the head.




supersport126 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 06-09-2013, 05:31 PM
roboto65
Registered User
1976 CJ5 
 
Join Date: Mar 2012
Location: Conroe
Posts: 769
See how the end of the valve cover is tapered down in the front is it like that in the back that taper could be the cause.

They say money can't buy happiness but it can buy Jeep parts...and Jeep parts make me really Happy.
roboto65 is offline  
post #3 of 19 Old 06-09-2013, 05:43 PM
gmakra
Registered User
1985 CJ7 
 
Join Date: Jun 2008
Location: Chicago area
Posts: 3,560
What valve springs are you running?
It is known that some larger diameter springs interfere with the valve cover.
gmakra is offline  
post #4 of 19 Old 06-09-2013, 06:22 PM
I6CJ7
Registered User
1984 CJ7 
 
Join Date: Aug 2009
Location: Virginia
Posts: 1,095
My guess is the baffles for that valve cover ports (pcv and vent) hang lower and are hitting. What gasket do you have? The cork gaskets add quite a bit of height that may clearance it.
I6CJ7 is offline  
post #5 of 19 Old 06-09-2013, 06:26 PM
james04si
Senior Member
 
james04si's Avatar
1977 CJ5 
 
Join Date: Apr 2009
Location: Arlington TX
Posts: 853
Agree with gmakra. I have the Clearwater head with as valves and had to grind down the valve cover around a couple of the valves for it to sit correctly. There is plenty of meat on the valve cover and it just needs a little grinding to sit flush.
james04si is offline  
post #6 of 19 Old 06-09-2013, 08:19 PM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
It's not the ports, those I could measure. I'll try put some masking tape across the valve springs and see if I notice any marking after setting the cover back on
supersport126 is offline  
post #7 of 19 Old 06-09-2013, 09:37 PM
holliewood61
Web Wheeler
 
holliewood61's Avatar
1981 CJ7 
 
Join Date: May 2013
Location: Peterstown
Posts: 1,465
I gotta ask. Why do you have the bridge cut off #1

08 WK bone stock
00 WJ daily driver
99 TJ mostly stock 97 TJ cheap jeep
81 CJ7 very little stock
60 CJ5 tore down
holliewood61 is offline  
post #8 of 19 Old 06-10-2013, 05:17 AM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
Quote:
Originally Posted by roboto65 View Post
See how the end of the valve cover is tapered down in the front is it like that in the back that taper could be the cause.
Yes its taped in the rear also
Quote:
Originally Posted by gmakra View Post
What valve springs are you running?
It is known that some larger diameter springs interfere with the valve cover.
what ever springs Clearwater uses (I dont know)

Quote:
Originally Posted by holliewood61 View Post
I gotta ask. Why do you have the bridge cut off #1
Good eye, stupid me thought it was hitting the bridges so I cut one to find out......I have another on order
supersport126 is offline  
post #9 of 19 Old 06-10-2013, 11:44 AM
JrTjK
Registered User
1978 FSJ Wagoneer 
 
Join Date: Jan 2006
Location: South Shore MA
Posts: 1,180
What year is the head setup? As those valve covers are said to usually only fit 93-04*ish.
JrTjK is offline  
post #10 of 19 Old 06-10-2013, 12:30 PM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
Not sure what year, it's not stamped. It's whatever year Clearwater uses . Gonna mask off the inside of cover and see if I can notice where it's hitting when I get home today.
supersport126 is offline  
post #11 of 19 Old 06-10-2013, 04:26 PM
Nereussailor
Registered User
1984 CJ7 
 
Join Date: Sep 2010
Location: Vero Beach
Posts: 645
I'd be trying to get a hold of Clearwater and ask.

I'm not sure what tomorrow will bring, but it can't be any worse than what I've already been through.
Nereussailor is offline  
post #12 of 19 Old 06-10-2013, 08:18 PM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
Clearwater wouldn't even tell me what springs they used...trust me they aren't too helpful. I bought a 500 head and had to do 300 dollars worth of head work for it to work with my cam....( long story)
supersport126 is offline  
post #13 of 19 Old 06-13-2013, 09:01 PM Thread Starter
supersport126
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Michigan
Posts: 953
Well got around to masking the inside of valve cover and looks like the first and last valve spring retainers are hitting. I'm gonna first file the outside where it's tight against the ARP head bolts (drivers side) and then try and carefully grind the inside a bit

supersport126 is offline  
post #14 of 19 Old 06-14-2013, 06:17 AM
james04si
Senior Member
 
james04si's Avatar
1977 CJ5 
 
Join Date: Apr 2009
Location: Arlington TX
Posts: 853
Sounds good. That's exactly what I did. Like I said that valve cover has plenty you can take off and as you can see it really doesn't need that much to work. I used an air die grinder and had no issues.
james04si is offline  
post #15 of 19 Old 06-14-2013, 10:34 AM
jeepwhore
Registered User
1984 CJ7 
 
Join Date: Jun 2006
Location: Kamloops
Posts: 3,960
Quote:
Originally Posted by supersport126 View Post
Clearwater wouldn't even tell me what springs they used...trust me they aren't too helpful. I bought a 500 head and had to do 300 dollars worth of head work for it to work with my cam....( long story)
Now now, we did determine part of that whole debacle was due to them not having received all the pertinent info......

As for the interference, it is a pretty well documented problem in the stroker community and came up in several google searches when I was researching cams for my head swap. So it's not specific to clearwater heads, per se.

'84 CJ-7: Yota axles (spartan locked front, e-locked rear) 4" BDS, 1" Daystar & 3/8" shackle lifts, 35" X-Terrains on steelies, YJ Tub & family roll bar, heater blower upgrade, 4.2L w/MC2100 & Team Rush, Warn 8274. Rebuilt 4.2/4.0 hybrid, AX15 and twin sticks/clocking ring waiting to go in.

The advertised position for a topless, dirty jeep girl has been filled......by my wife. Thanks to all that applied.
<------------and yes, that is her.
:-D
jeepwhore is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome