My 86 cj7 will not shut off with key switch - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > My 86 cj7 will not shut off with key switch

ZONE 4.25" combo lift for TJ available at Rockridge4wJeep Wrangler Bushwacker Flat Fender Flare Sale at BaselinRIGID LED Light Blowout Sale - All Sizes, All Series, all

Reply
Unread 12-05-2012, 08:13 PM   #31
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,690
You pulled the two prong connector out of the back of the alternator and it stayed running, correct?

86cj74.2L is online now   Reply With Quote Quick reply to this message
Unread 12-05-2012, 11:30 PM   #32
BagusJeep
Web Wheeler
 
BagusJeep's Avatar
1981 CJ7 
 
Join Date: Jul 2009
Location: Bali, Indonesia
Posts: 4,448
Quote:
Originally Posted by DENVAR03 View Post
Hi
i rechecked wiring,and it looks ok.i tried pulling the 2 wire connector off alt.,when running,and it still runs!!!!.also i tried pulling the red/wht. Wire off solenoid,but engine still runs.had to pull dist wire to coil to shut down.what could be wrong?????>
One of the early questions was whether disconnecting the alternator changed anything. Apparently not.

So we have been through the possible causes:

1. Feedback from alternator. No, it makes no difference when disconnected.
2. incorrectly adjusted ignition switch. No, there is no power to the Red/white wires in STOP/OFF.
3. Faulty solenoid. No, it can be disconnected and makes no difference.
4. Wired coil to a Red wire (permanently on). No it turns on and off OK if it has not been running.

I am stumped. The only thing I can think is that this is an intermittenet feedback issue and the diode is still needed. It is a cheap and quick bit to install.
__________________
BagusJeep lives in Bali, the Land of Temples.
With a Jeep every prayer counts.

1981 CJ7 258ci - Bagusjeep
1984 CJ7 258ci - Puthijeep
1981 J20 258ci - Gladys
1995 Cherokee 4.0 - CHEROKEE
BagusJeep is offline   Reply With Quote Quick reply to this message
Unread 12-06-2012, 12:05 AM   #33
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,690
It be nice to have him probe the plus of the coil with the test light and shut off engine and tell what the bulb does while engine runs.

If it shuts off by its self after a few seconds,if I read the one reply correctly, I'd lean towards the switch adjustment. With the connector pulled from the alt I don't see how any feedback can still be happening it doesn't stop engine from running when it's pulled.
86cj74.2L is online now   Reply With Quote Quick reply to this message
Unread 12-06-2012, 01:37 PM   #34
DENVAR03
Registered User
1986 CJ7 
 
Join Date: Nov 2011
Location: BRICK, NEW JERSEY
Posts: 173
Id another testing today!!!!!!!!!

Engine off: Key off
coil- nothing
sol.- nothing
engine off:key on
coil-dim
sol-dim
alt-red screw lug wire-hot
2 wire plug,both wires-hot

engine running:
Coil-bright
sol-bright
pulled 2wire plug out,and engine still runs,and rpm picked up a little,and both wires read hot!!.

The first time i shut it down,it stopped immediately,next time 2 sec.,next time 3-4 sec,last time,about 5 sec.

Dennis
DENVAR03 is offline   Reply With Quote Quick reply to this message
Unread 12-06-2012, 03:53 PM   #35
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,690
When the engine stops a few seconds after you turn off ignition and your holding your keys in your hand.......to me anyway........is the switch adjustment.

The two prong connector is what you pull if engine stays running with your ignition keys in your hand to test if you need the diode.
86cj74.2L is online now   Reply With Quote Quick reply to this message
Unread 12-06-2012, 06:21 PM   #36
DENVAR03
Registered User
1986 CJ7 
 
Join Date: Nov 2011
Location: BRICK, NEW JERSEY
Posts: 173
Guess i did it the wrong way!!!
I will test for diode again.i pulled plug,with engine running,and key in and on.i will shut,with key in hand,and test alt. Plug.

Thanks dennis
DENVAR03 is offline   Reply With Quote Quick reply to this message
Unread 12-07-2012, 12:53 PM   #37
DENVAR03
Registered User
1986 CJ7 
 
Join Date: Nov 2011
Location: BRICK, NEW JERSEY
Posts: 173
Cj74


think i am ready to throw the rope ,with the loop over the beam!!!!!!!!.went out to do the check,on alt.,and started it up 5 times,and it shut off immediately!!!!!!no time to run around other side to pull plug off alt.i will post again,if the delay starts up again!!.

Thanks for now

dennis
DENVAR03 is offline   Reply With Quote Quick reply to this message
Unread 04-19-2013, 07:37 AM   #38
Chlarock
Registered User
1984 CJ7 
 
Join Date: Nov 2011
Location: carmel, new york
Posts: 70
Same problem

I had the same thing happen. all you guys are over thinking it. You have the constant power going to the wrong wire. It was a while ago but I think it was yellow. Look at the ingintio wires on the column and figure out were that power wire goes. Its just spliced to the wrong connection.
Chlarock is offline   Reply With Quote Quick reply to this message
Unread 04-19-2013, 05:49 PM   #39
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,690
For me and Grammys CJ it was the starter solenoid start bypass contacts were bad.
86cj74.2L is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.