motorcraft 2150 help - coming off idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > motorcraft 2150 help - coming off idle

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineTruc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955Toxic Brakes - 3000 PSI Braided Stainless Steel Brake Line

Reply
Unread 07-08-2008, 07:42 PM   #1
Jermy01
Registered User
1978 CJ7 
 
Join Date: Sep 2004
Location: Santa Barbara, ca
Posts: 205
motorcraft 2150 help - coming off idle

hey guys. so i just got my rebuilt motor into my jeep. Motor runs good, but the carb definately needs a little help.

my biggest part is when i am coming off idle, especially if i just barely push the pedal, it cuts out. i rebuilt the carb when i was rebuilding the motor, but if i remember correctly it was doing that before i started the rebuild. the accelerator pump is working fine, and i tried adjusting the throw for the accelerator pump, still did the same thing. It does it whether its hot or cold. i did notice my carb is missing the dashpot on the throttle positioner, but i thought this was only for coming down to idle (which it does bog a little there too)

any help would be great. thanks

__________________
-Jeremy

1978 CJ7, front and rear locker, 31'' BFG mud Terrain, superior axles. RE 2.5" lift. 304 V8. Warn M8000.
Jermy01 is offline   Reply With Quote
Unread 07-09-2008, 11:48 AM   #2
Jermy01
Registered User
1978 CJ7 
 
Join Date: Sep 2004
Location: Santa Barbara, ca
Posts: 205
anyone???????
__________________
-Jeremy

1978 CJ7, front and rear locker, 31'' BFG mud Terrain, superior axles. RE 2.5" lift. 304 V8. Warn M8000.
Jermy01 is offline   Reply With Quote
Unread 07-09-2008, 11:54 AM   #3
JeepHammer
Running On Empty...
1973 CJ5 
 
Join Date: Aug 2007
Location: South West Indiana
Posts: 10,154
It's your accelerator pump adjustment.

You just described a classic case of accelerator pump linkage problems.

You have to make sure the accelerator pump throws fuel the INSTANT the throttle shaft starts to move when you are adjusting!
JeepHammer is offline   Reply With Quote
Unread 07-09-2008, 03:14 PM   #4
jeepdaddy2000
Web Wheeler
 
jeepdaddy2000's Avatar
1971 CJ5 
 
Join Date: Jan 2002
Location: Eagle Point Oregon
Posts: 6,199
Might double check the umbrella seal in the pump housing. If it wasn't installed properly, it can cause a bog due to not sealing properly. Also, insure the diaphragm isn't in back wards.
jeepdaddy2000 is offline   Reply With Quote
Unread 07-09-2008, 04:42 PM   #5
Jermy01
Registered User
1978 CJ7 
 
Join Date: Sep 2004
Location: Santa Barbara, ca
Posts: 205
i have played with the accelerator pump and it does squirt a shot as soon as i touch the throttle, will take it apart tho and make sure everything looks good in there
__________________
-Jeremy

1978 CJ7, front and rear locker, 31'' BFG mud Terrain, superior axles. RE 2.5" lift. 304 V8. Warn M8000.
Jermy01 is offline   Reply With Quote
Unread 07-09-2008, 09:39 PM   #6
coas
Registered User
 
Join Date: Apr 2005
Posts: 442
Beside adjusting the acc pump you might need a new diaphragm.


Should look like the left one, if it's distort, like the one on the right, the amount of fuel in a shot is too low:
(30 years old OEM diaphragm vs after market junk)
__________________
84 CJ7 , Dana 44 rear D30 front, 258, 4.0 head, MPFI, e-fans, T176, Dana 300, 31x10.5x15 and Mustang hydroboost.
My esnips folders:Jeep Jeep Transmissions
coas is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.