Lost top end speed - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Lost top end speed

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 04-22-2013, 08:14 PM   #1
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Lost top end speed

Just completed the CRT hei install and instantly noticed no more miss at idle and low end power smooth and increased. Problem is now it will barely hit 70. I increased the timing from 8 to 12 it helped alittle 72 but that's floored flat smooth highway. Before the change out I could cruise at 75 with pedal left. Any thoughts?

Sent from my iPhone using JeepForum

firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 02:10 AM   #2
John Strenk
Moderator
 
John Strenk's Avatar
1976 CJ5 
 
Join Date: Feb 2005
Location: Shalersville Ohio
Posts: 13,007
I would check the advance curve of the distributor you just installed. Maybe it needs soe tweeking.
Did you change plugs at the same time? What type did you use?
John Strenk is offline   Reply With Quote
Unread 04-23-2013, 04:28 AM   #3
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,431
Quote:
Originally Posted by firemanjim7
Just completed the CRT hei install and instantly noticed no more miss at idle and low end power smooth and increased. Problem is now it will barely hit 70. I increased the timing from 8 to 12 it helped alittle 72 but that's floored flat smooth highway. Before the change out I could cruise at 75 with pedal left. Any thoughts?

Sent from my iPhone using JeepForum
Do you hear detonation.
86cj74.2L is offline   Reply With Quote
Unread 04-23-2013, 04:50 AM   #4
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,017
What dizzy was in there before?

Matt
Matt1981CJ7 is online now   Reply With Quote
Unread 04-23-2013, 07:12 AM   #5
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Quote:
Originally Posted by John Strenk
I would check the advance curve of the distributor you just installed. Maybe it needs soe tweeking.
Did you change plugs at the same time? What type did you use?
Yes changed plugs. Champion copper

Sent from my iPhone using JeepForum
firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 07:14 AM   #6
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Quote:
Originally Posted by Matt1981CJ7
What dizzy was in there before?

Matt
Just a tad of detonation when I moved it to 12. The previous dizzy was stock.

Sent from my iPhone using JeepForum
firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 07:54 AM   #7
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,017
I'm with John on this one. Check the total advance curve (centrifugal + initial) of the hei.

If you kept the wiring for the Duraspark, you could also re-install it, then compare the curves. If timing is the issue, the top-end of the curves will likely tell the story.

Matt
Matt1981CJ7 is online now   Reply With Quote
Unread 04-23-2013, 08:09 AM   #8
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 6,431
If its a standard HEI curve and not altered for a 258 they have 20 total advance and it comes in quicker then it should
86cj74.2L is offline   Reply With Quote
Unread 04-23-2013, 09:08 AM   #9
swatson454
Mall-crawlin' Hot Rodder
 
swatson454's Avatar
1983 CJ7 
 
Join Date: May 2009
Location: Dripping Springs, TX (soon)
Posts: 4,780
What rpm is it knocking at? Can you be pretty descriptive of when it occurs?


Shawn
__________________
Live in a way that those who know you but don't know God will come to know God because they know you.
swatson454 is offline   Reply With Quote
Unread 04-23-2013, 09:36 AM   #10
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Quote:
Originally Posted by swatson454
What rpm is it knocking at? Can you be pretty descriptive of when it occurs?

Shawn
The knock is only under a hard load not any specific rpm. As for the curve set up I'm not sure it was ordered from CRT for the 258. I talked to mechanic and he seems to think I might need a vacuume delay valve thinking it is loosing vacuum too quickly at WOT and loosing advance.

Sent from my iPhone using JeepForum
firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 09:40 AM   #11
82JeepCJ7
Registered User
1982 CJ7 
 
Join Date: Jun 2010
Location: Marysville, WA
Posts: 4,813
I had the same issue with my HEI. I adjusted the vacuum advance curve (allen wrench goes in where the vacuum line attaches on the advance). Until I adjusted the curve, I could get good idle and regular running, but when advancing hard, it would ping.
__________________
Beat it to fit, paint it to match!

Wheel, Wrench, Repeat.
82JeepCJ7 is offline   Reply With Quote
Unread 04-23-2013, 09:46 AM   #12
swatson454
Mall-crawlin' Hot Rodder
 
swatson454's Avatar
1983 CJ7 
 
Join Date: May 2009
Location: Dripping Springs, TX (soon)
Posts: 4,780
Quote:
Originally Posted by firemanjim7 View Post
The knock is only under a hard load not any specific rpm. As for the curve set up I'm not sure it was ordered from CRT for the 258. I talked to mechanic and he seems to think I might need a vacuume delay valve thinking it is loosing vacuum too quickly at WOT and loosing advance.

Sent from my iPhone using JeepForum
You really need to remove and plug the vacuum advance and accelerate hard up to redline. This should isolate your problem: either vacuum advance issue (if the knocking goes away) or the centrifugal curve/initial advance setting.

It's a crapshoot without knowing exactly where your problem lies. You might get lucky and make it quit knocking but you won't know if you just slapped a band aid on it; in which case, performance everywhere else could suffer.


Shawn

Edit: if you only got a touch of detonation when you went to 12*, I don't suspect you have a vacuum advance issue. It might be happy just backing off the initial advance 2*.
__________________
Live in a way that those who know you but don't know God will come to know God because they know you.
swatson454 is offline   Reply With Quote
Unread 04-23-2013, 09:50 AM   #13
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Quote:
Originally Posted by 82JeepCJ7
I had the same issue with my HEI. I adjusted the vacuum advance curve (allen wrench goes in where the vacuum line attaches on the advance). Until I adjusted the curve, I could get good idle and regular running, but when advancing hard, it would ping.
Which way did you adjust in or out ? What did your initial timing end up being?

Sent from my iPhone using JeepForum
firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 09:52 AM   #14
firemanjim7
Registered User
1983 CJ7 
 
Join Date: Dec 2010
Location: Giddings, Tx
Posts: 150
Quote:
Originally Posted by swatson454

You really need to remove and plug the vacuum advance and accelerate hard up to redline. This should isolate your problem: either vacuum advance issue or the centrifugal curve/initial advance setting.

It's a crapshoot without knowing exactly where your problem lies. You might get lucky and make it quit knocking but you won't know if you just slapped a band aid on it; in which case, performance everywhere else could suffer.

Shawn
I'm pretty sure my knocking is coming from too much initial advance.

Sent from my iPhone using JeepForum
firemanjim7 is offline   Reply With Quote
Unread 04-23-2013, 09:56 AM   #15
swatson454
Mall-crawlin' Hot Rodder
 
swatson454's Avatar
1983 CJ7 
 
Join Date: May 2009
Location: Dripping Springs, TX (soon)
Posts: 4,780
Sorry dude, I snuck an edit in there
__________________
Live in a way that those who know you but don't know God will come to know God because they know you.
swatson454 is offline   Reply With Quote
Reply
Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.