Jeep running rough as hell -replaced carb still running the same. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Jeep running rough as hell -replaced carb still running the same.

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFREE Shipping Sale!FS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 07-25-2015, 08:54 PM   #1
agear
Registered User
1984 CJ7 
 
Join Date: May 2011
Location: norfolk, virginia
Posts: 2,101
Cj Jeep running rough as hell -replaced carb still running the same.

My jeep started sputtering one day on the way home from work . Before hand it had been running fine. I had the weber 32/36 or whatever. I got my brother in law to adjust the carburetor and I replaced both of my fuel filters - it ran better for a few then started running like crap again. My brother in law thought it might be trash in the carburetor. So this was a great excuse to upgrade to the 390 cfm 38 weber carburetor. I put it on and its still running the same way. With the jeep running I wiggled my alternator wires and my coil wires but that didn't make it how it was running change. I also looked at my module from under the jeep and didn't see anything melted and kind of dripping down. I looked at the lines and hoses at my gas tank and I don't see or smell any gas leaking. Could it be the fuel pump ?

__________________
1984 jeep cj7, 258 I6, rebuilt T176,rebuilt Dana 300, amc 20 , dana 30, 4.10's Trac-lok in rear , 4.10's detroit soft locker in dana 30, 2.5 inch bds suspension lift, 1 inch polyurethan body mount lift. Line ex. weber carburetor. factory tach. factory clock ,oem replacement speedomter cluster, and oil pressure gauge, factory volt gauge.
agear is offline   Reply With Quote Quick reply to this message
Unread 07-26-2015, 05:30 AM   #2
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 16,491
Dirty distributor cap and rotor?
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote Quick reply to this message
Unread 07-26-2015, 06:47 AM   #3
Cashcrazy
Registered User
1983 CJ7 
 
Join Date: May 2013
Location: Tyler, TX
Posts: 342
Did you check spark plugs?
__________________
1982 CJ7(sold), 1983 CJ7(sold), 1989 YJ(sold), 1983 CJ7 undergoing frame-off.
Cashcrazy is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 02:32 PM   #4
agear
Registered User
1984 CJ7 
 
Join Date: May 2011
Location: norfolk, virginia
Posts: 2,101
I looked at the spark plugs a month ago when I did my head gasket -they all had a tan spot on there except one which had a black spot. Haven't looked at the cap and rotor yet but I'm sending the carburetor back for a replacement because the secondary throttle was binding a little but I don't believe that was my issue because it ran the same with new carburetor as it did with the old
__________________
1984 jeep cj7, 258 I6, rebuilt T176,rebuilt Dana 300, amc 20 , dana 30, 4.10's Trac-lok in rear , 4.10's detroit soft locker in dana 30, 2.5 inch bds suspension lift, 1 inch polyurethan body mount lift. Line ex. weber carburetor. factory tach. factory clock ,oem replacement speedomter cluster, and oil pressure gauge, factory volt gauge.
agear is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 02:59 PM   #5
Skerr
Registered User
1985 CJ7 
 
Join Date: Sep 2008
Location: White Springs, Florida
Posts: 8,974
Intake leak? Sure will make it run poorly.
__________________
Kerrdog
Go Fish! <*////><

But the right word at the right time... "Hey, give me a little hug!" That's the difference between lightning and a harmless lightning bug!
Skerr is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 05:15 PM   #6
Colubrid
Registered User
1979 CJ7 
 
Join Date: Jul 2015
Location: Martinsville, Indiana
Posts: 1
agear, Post if you get this fixed, my 79 started doing the same recently. The stock carb was removed and "cleaned" twice, ran good for two days then messed up again. I'm wondering if bad gas or crap in the gas tank might cause this... This is my first post by the way, glad to be here.
Colubrid is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 05:28 PM   #7
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 13,309
agear,

I think we need a little more info. "Running rough as hell..." doesn't quite do it.

What are the symptoms? Does it run OK warm or cold? Or is rough all the time?

You mentioned one black spark plug. Have you confirmed spark in that cylinder?

Matt
Matt1981CJ7 is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 11:13 PM   #8
ikidd
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Edmonton, Alberta
Posts: 136
So you replaced the fuel filters and it ran better for a while, then went to hell again? Are you able to cut open the old ones and see if they were plugged? Maybe the new ones are as well now, and that will tell you something.
__________________
1998 ZJ 5.9 - 4", NP242
1998 ZJ 4.0 - Stock
1977 CJ7 304 Auto
1994 ZJ 4.0 "Rammy" RIP
ikidd is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.