installed new ignition, carb & manifold on my 304 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 05-25-2004, 06:42 PM Thread Starter
Marc CJ7
Registered User
 
Join Date: Feb 2003
Location: PA
Posts: 115
installed new ignition, carb & manifold on my 304

Just got finished upgrading my stock 304 points ignition, 2bbl carb and manifold to a DUI, Edelbrock 600 cfm carb & performer manifold. Man what a difference, its like a totally new engine under the hood. Im able to spin the tires from a roll in 2nd gear .

Everything was running fine for the inital test drive, I went about 1 mile and came back home to clean up the tools and I jump back in to take another ride but I only made it about 50' and it dies on me. I think its electrical because the starter is spinning but its not sparking. I checked the jungle that I call the fuse block and found some fuses that looked broke so I threw new ones in there but still no spark??? Anyone have any ideas, I'm open for suggestions... even stupid ones.

Thanks


82 CJ7 - 304 / T5
98 GTI VR6
All Motor: 1.89 - 13.55 @ 101.60
12.641 @ 110mph - spraying
Marc CJ7 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-25-2004, 10:33 PM
CJ-5
Registered User
 
Join Date: Mar 2004
Location: Saskatoon, Sk. Canada
Posts: 215
New

check all the new stuff first, maybe you never tightened somthing down or somthing was not quiet plugged in all the way, and came loose on your little rip around the neighbourhood.
CJ-5 is offline  
post #3 of 5 Old 05-26-2004, 06:09 AM Thread Starter
Marc CJ7
Registered User
 
Join Date: Feb 2003
Location: PA
Posts: 115
went over everthing again last night but didn't see what the problem was. Today when I get home I will use the multi-meter & test light to see what the problem is. I am almost 100% sure its spark related because the starter spins but the plug wires don't arch... still open for suggestions.

thanks

82 CJ7 - 304 / T5
98 GTI VR6
All Motor: 1.89 - 13.55 @ 101.60
12.641 @ 110mph - spraying
Marc CJ7 is offline  
post #4 of 5 Old 05-26-2004, 02:51 PM Thread Starter
Marc CJ7
Registered User
 
Join Date: Feb 2003
Location: PA
Posts: 115
Quote:
Originally Posted by Marc CJ7
went over everthing again last night but didn't see what the problem was. Today when I get home I will use the multi-meter & test light to see what the problem is. I am almost 100% sure its spark related because the starter spins but the plug wires don't arch... still open for suggestions.

thanks
just wanted to add one question to the post, what kind of vacume advance system does a 304 have? The carb says there are 2 kinds (vacume advanced & something else I can't recall) of different systems, I just want to make sure I have my vacume hose coming off the D.U.I.

Thanks.

82 CJ7 - 304 / T5
98 GTI VR6
All Motor: 1.89 - 13.55 @ 101.60
12.641 @ 110mph - spraying
Marc CJ7 is offline  
post #5 of 5 Old 05-26-2004, 05:58 PM Thread Starter
Marc CJ7
Registered User
 
Join Date: Feb 2003
Location: PA
Posts: 115
OK, I found the problem. The drive gear on the D.U.I. distributor is worn out, it probably happened when I started the jeep up the first time and didn't have the distrbuter clamped all the way down. It sounded like a crunching noise just like when it died on me yesterday. So does anyone know where I can get a new on of these??

where can I find a 304 AMC V8 D.U.I. distributor drive gear???

thanks.

82 CJ7 - 304 / T5
98 GTI VR6
All Motor: 1.89 - 13.55 @ 101.60
12.641 @ 110mph - spraying
Marc CJ7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Intake manifold and carb swap Jaxson09 Jeep CJ Forum 4 08-07-2009 11:55 PM
Challenging Carb/ignition problem. I'm stumped Brad79CJ Jeep CJ Forum 6 08-04-2008 08:48 PM
Carb and Manifold jeepvosser Jeep CJ Forum 4 08-07-2006 05:34 PM
Manifold+carb recommendations? vladrulli Jeep CJ Forum 7 07-12-2006 07:22 PM
need a new manifold & carb for the CJ Marc CJ7 Jeep CJ Forum 6 02-14-2004 09:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome