Howell TBI O2 Sensor -

LinkBack Thread Tools
post #1 of 2 Old 06-02-2013, 06:28 PM Thread Starter
Registered User
1978 CJ5 
Join Date: Aug 2012
Location: Greenville
Posts: 173
Howell TBI O2 Sensor

The O2 sensor went out already went out on my 1 yr old Howell TBI system and the ECU is shooting code "13". I have the heated version and it it located in the header collector just before the muffler and run a 304. Is this normal? I thought those last many years. Is it possible to fool the ECU into thinking it is working? I am under no emissions testing and do not have to get the Jeep inspected ever again.



Jbwardfamily is offline  
Sponsored Links
post #2 of 2 Old 06-02-2013, 09:07 PM
Registered User
Join Date: Aug 2002
Location: Colorado
Posts: 15,815
The oxygen sensor is the main sensor in getting the air/fuel mixture right. It's not just there for emissions purposes.

Typically they do last for years. You may have ended up with a bad one, which happens every once in a while with any part.
CSP is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome