help with my jeep - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > help with my jeep

Clayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank SkidTJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 05-24-2004, 11:52 PM   #1
RickLopez
Registered User
1980 CJ7 
 
Join Date: May 2004
Posts: 52
help with my jeep

Its an 1980 (O|||O) CJ7
original 304 V8 with performance parts
Auto tranny
Dana 300
http://freehost03.websamba.com/cool-cars/car.htm
2 problems...
When I press the brake pedal all lights (gauges,headlights,...)
turn on. I've been told that the problem may be with the wiring harness located at the sterring column (behing the steering wheel) and grounding. (but how)
The other problem is the front driveshaft.
I notised that the front driveshaft is hitting the trannys oil pan.
My dad says its the engine & tranny mounts.
Does it have to hit at all on extreme articulation?
Im taking it to school soon, so I really need help.

RickLopez is offline   Reply With Quote
Unread 05-25-2004, 09:21 AM   #2
jeepsarecool
Registered User
1982 CJ7 
 
Join Date: Jan 2003
Location: Alabama
Posts: 1,138
Quote:
Originally Posted by RickLopez
Its an 1980 (O|||O) CJ7
original 304 V8 with performance parts
Auto tranny
Dana 300
http://freehost03.websamba.com/cool-cars/car.htm
2 problems...
When I press the brake pedal all lights (gauges,headlights,...)
turn on. I've been told that the problem may be with the wiring harness located at the sterring column (behing the steering wheel) and grounding. (but how)
The other problem is the front driveshaft.
I notised that the front driveshaft is hitting the trannys oil pan.
My dad says its the engine & tranny mounts.
Does it have to hit at all on extreme articulation?
Im taking it to school soon, so I really need help.
As for the lights, my guess would be that you have some sort of short. The dash lights are getting power SOMEhow when you press the brake. Either something is wired wrong, or there's a bad connection or bare wire somewhere. You'll have to get a manual and dig through them, and that's no fun.

Your driveshaft definitely shouldn't hit the oil pan. Did you check the motor and tranny mounts? You do have a heavy motor.

I'm no expert on either matter, just chiming in.
__________________
Check out my Art


CJ7 - God's gift to the masochist.
jeepsarecool is offline   Reply With Quote
Unread 05-25-2004, 05:40 PM   #3
RickLopez
Registered User
1980 CJ7 
 
Join Date: May 2004
Posts: 52
Help....
Help......
Help........
RickLopez is offline   Reply With Quote
Unread 05-25-2004, 07:23 PM   #4
jeepdaddy2000
Web Wheeler
 
jeepdaddy2000's Avatar
1971 CJ5 
 
Join Date: Jan 2002
Location: Eagle Point Oregon
Posts: 6,186
Check to make sure your rear light housings are grounded. If the ground is bad, the brake lights will ground through the taillights causing the system to light up. The other problem might be deeper, most CJ's have had massive hacking and modification done to their wiring. You might have to check under the dash for some prior "mods".
jeepdaddy2000 is offline   Reply With Quote
Unread 05-25-2004, 09:26 PM   #5
RickLopez
Registered User
1980 CJ7 
 
Join Date: May 2004
Posts: 52
I checked the rear tail lghts, removed the light bulbs and every thing worked fine. Later I found out that my right tail light had a bad socket and a lightbulb. THANKS for all your help.
But I still need to replace the bad tranny mounts.
RickLopez is offline   Reply With Quote
Unread 05-25-2004, 09:28 PM   #6
RickLopez
Registered User
1980 CJ7 
 
Join Date: May 2004
Posts: 52
is there a way to fix the speedometer readings. I have 35 inch tires.
RickLopez is offline   Reply With Quote
Unread 05-26-2004, 03:51 PM   #7
livin2learn
Registered User
 
Join Date: Dec 2002
Posts: 57
You can get a new speedo gear.

http://www.jeeptech.com/javaAps/Speedo.html

http://www.sierrajeep.com/speedome.htm
__________________
[URL=http://community.webshots.com/user/livin2learn ]'83 CJ-7 Renegade[/URL], I6-258, T-4, 1" M.O.R.E. BL, RE 2.5", Weber Carb, 33" ProComp MT
livin2learn is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.