help with my jeep - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 05-24-2004, 11:52 PM Thread Starter
RickLopez
Registered User
 
RickLopez's Avatar
1980 CJ7 
 
Join Date: May 2004
Posts: 52
help with my jeep

Its an 1980 (O|||O) CJ7
original 304 V8 with performance parts
Auto tranny
Dana 300
http://freehost03.websamba.com/cool-cars/car.htm
2 problems...
When I press the brake pedal all lights (gauges,headlights,...)
turn on. I've been told that the problem may be with the wiring harness located at the sterring column (behing the steering wheel) and grounding. (but how)
The other problem is the front driveshaft.
I notised that the front driveshaft is hitting the trannys oil pan.
My dad says its the engine & tranny mounts.
Does it have to hit at all on extreme articulation?
Im taking it to school soon, so I really need help.

RickLopez is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-25-2004, 09:21 AM
jeepsarecool
Registered User
 
jeepsarecool's Avatar
1982 CJ7 
 
Join Date: Jan 2003
Location: Alabama
Posts: 1,138
Quote:
Originally Posted by RickLopez
Its an 1980 (O|||O) CJ7
original 304 V8 with performance parts
Auto tranny
Dana 300
http://freehost03.websamba.com/cool-cars/car.htm
2 problems...
When I press the brake pedal all lights (gauges,headlights,...)
turn on. I've been told that the problem may be with the wiring harness located at the sterring column (behing the steering wheel) and grounding. (but how)
The other problem is the front driveshaft.
I notised that the front driveshaft is hitting the trannys oil pan.
My dad says its the engine & tranny mounts.
Does it have to hit at all on extreme articulation?
Im taking it to school soon, so I really need help.
As for the lights, my guess would be that you have some sort of short. The dash lights are getting power SOMEhow when you press the brake. Either something is wired wrong, or there's a bad connection or bare wire somewhere. You'll have to get a manual and dig through them, and that's no fun.

Your driveshaft definitely shouldn't hit the oil pan. Did you check the motor and tranny mounts? You do have a heavy motor.

I'm no expert on either matter, just chiming in.

Check out my Art


CJ7 - God's gift to the masochist.
jeepsarecool is offline  
post #3 of 7 Old 05-25-2004, 05:40 PM Thread Starter
RickLopez
Registered User
 
RickLopez's Avatar
1980 CJ7 
 
Join Date: May 2004
Posts: 52
Help....
Help......
Help........
RickLopez is offline  
post #4 of 7 Old 05-25-2004, 07:23 PM
jeepdaddy2000
Registered User
 
jeepdaddy2000's Avatar
1971 CJ5 
 
Join Date: Jan 2002
Location: Eagle Point
Posts: 7,136
Check to make sure your rear light housings are grounded. If the ground is bad, the brake lights will ground through the taillights causing the system to light up. The other problem might be deeper, most CJ's have had massive hacking and modification done to their wiring. You might have to check under the dash for some prior "mods".
jeepdaddy2000 is offline  
post #5 of 7 Old 05-25-2004, 09:26 PM Thread Starter
RickLopez
Registered User
 
RickLopez's Avatar
1980 CJ7 
 
Join Date: May 2004
Posts: 52
I checked the rear tail lghts, removed the light bulbs and every thing worked fine. Later I found out that my right tail light had a bad socket and a lightbulb. THANKS for all your help.
But I still need to replace the bad tranny mounts.
RickLopez is offline  
post #6 of 7 Old 05-25-2004, 09:28 PM Thread Starter
RickLopez
Registered User
 
RickLopez's Avatar
1980 CJ7 
 
Join Date: May 2004
Posts: 52
is there a way to fix the speedometer readings. I have 35 inch tires.
RickLopez is offline  
post #7 of 7 Old 05-26-2004, 03:51 PM
livin2learn
Registered User
 
livin2learn's Avatar
 
Join Date: Dec 2002
Posts: 57
You can get a new speedo gear.

http://www.jeeptech.com/javaAps/Speedo.html

http://www.sierrajeep.com/speedome.htm

'83 CJ-7 Renegade, I6-258, T-4, 1" M.O.R.E. BL, RE 2.5", Weber Carb, 33" ProComp MT
livin2learn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Jeep Turning Radius (Jeep Turns To The LEFT Great, Not So Much To The RIGHT) Military Jeeper Jeep CJ Forum 8 02-27-2008 10:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome