Help with leaks? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Help with leaks?

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 04-04-2009, 10:41 AM   #1
newjeepowner
Registered User
 
Join Date: Oct 2007
Location: ct
Posts: 116
Help with leaks?

I took off my tranny cover last week and cleaned everything up on the top and down below so I could try and locate my leaks. I also changed the gear oil from the tranny (not the transfer case)..

After driving about 15 miles (or less). this is what I have.

Top of tranny does not appear to be leaking...I tighted the plugs on the top though as they were loose

Bottom seems to have a number of probs.....to me, it looks like oil is leaking where the engine lines up to the tranny (pix one) and that somewhere in the transmission or transfer case I have a bleeder.

The transfer case drain plug (not pictured) is also very wet but it might be just running down from the side. To me, it seems that it might be coming from the linkage area of the transfer case but I'm not sure...

Also, while it looks wet, the fill plug on the transmission isn't leaking..

It does look like the gear oil is getting spread around a lot though I did not drive in 4 wheel drive so I'm not sure whats going on

Any help in identifying possible cause (or what I'm in for, or how to fix) is appreciated. I've course, $ is tight and if the leaks are slow, I'll live w/them. However, the tranny leak seems a bit more urgent







newjeepowner is offline   Reply With Quote
Unread 04-04-2009, 11:55 AM   #2
Coiz
Registered User
1979 CJ7 
 
Join Date: Mar 2008
Location: Northern, IL
Posts: 4,168
The first picture looks like it is coming from the rear main seal on the engine not from the trans. Is that engine oil?

The bottom picture looks wet all over and could be from the transfer case shift rods seals or the front yoke. The front yoke will/would sling oil outwards and cover the side of the trans. You can try sealing the trans fill plug with Teflon tape or similar to see if that helps.
__________________
Mike
My build thread
1979 CJ7, FI 5.0L Ford, NP435, D300, Full floated D44 Detroit, D30 Detroit EZ Locker.
Coiz is offline   Reply With Quote
Unread 04-04-2009, 12:11 PM   #3
newjeepowner
Registered User
 
Join Date: Oct 2007
Location: ct
Posts: 116
Quote:
Originally Posted by Coiz View Post
The first picture looks like it is coming from the rear main seal on the engine not from the trans. Is that engine oil?

The bottom picture looks wet all over and could be from the transfer case shift rods seals or the front yoke. The front yoke will/would sling oil outwards and cover the side of the trans. You can try sealing the trans fill plug with Teflon tape or similar to see if that helps.
Based on the degree of wetness sounds more like the front yoke but could be the other one you mention.

How hard are these to fix? I know the seals don't cost a lot but can this be done under the vehicle w/o a lot of tools? If not, looks like I'm heading to the garage

thanks for the reply
newjeepowner is offline   Reply With Quote
Unread 04-04-2009, 01:24 PM   #4
JeffMcBusa
Registered User
1979 CJ7 
 
Join Date: Mar 2009
Location: Visalia, Ca
Posts: 177
I gotta agree with Coiz. I just replaced my rear main seal because I had MOTOR oil in the same place as your first pic. I also have some leakage in the same area as your last pic but not bad and I am monitoring it. The RMS is a *****, or was for me. I have leakage coming from the shifter where that domed cap is. I remember you posting a oic awhile ago regarding that wire (spark control). Did you change a seal below the shifter? I think I need to do that and want to be sure I don't get in over my head.
JeffMcBusa is offline   Reply With Quote
Unread 04-04-2009, 01:50 PM   #5
newjeepowner
Registered User
 
Join Date: Oct 2007
Location: ct
Posts: 116
Quote:
Originally Posted by JeffMcBusa View Post
I gotta agree with Coiz. I just replaced my rear main seal because I had MOTOR oil in the same place as your first pic. I also have some leakage in the same area as your last pic but not bad and I am monitoring it. The RMS is a *****, or was for me. I have leakage coming from the shifter where that domed cap is. I remember you posting a oic awhile ago regarding that wire (spark control). Did you change a seal below the shifter? I think I need to do that and want to be sure I don't get in over my head.

I didn't change change the seal. I just cleaned the heck out of everything. based on what I'm hearing here, I might bring it in to have a few things done...wife isn't going to like it though...
newjeepowner is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.