Help I think my PCM is bad on my 4.0L ? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 12 Old 07-15-2015, 07:44 AM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
Help I think my PCM is bad on my 4.0L ?

Ive had a start issue and assumed it was the starter switch down on the steering column. I installed a new one. This was not it. I installed new relays both the ASD relay and Fuel pump relay thinking one or the other or both were bad. Still not it, wont start. Fuel pump is silent so relay is not getting pulled in.

Do i need to check the CPS?

I have a 95 OBD1 engine with Hesco harmonic balancer mounted CPS.

If this checks ok can it be a BAD PCM ?

I hooked up a code scanner and I get " no connection to vehicle". It always scanned before, but now nothing.

How does the PCM get power through the ignition switch? I can take a volt ohm meter and check the pins for voltage?

thanks chuck


81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
Sponsored Links
Advertisement
 
post #2 of 12 Old 07-15-2015, 08:22 AM
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant
Posts: 18,089
You would be better off in the YJ forum. They are used to pcm issues. No codes is one symptom of the 15 capacitors blowing out and there are test points to verify that.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline  
post #3 of 12 Old 07-15-2015, 10:54 AM
TIPPEDITOVER
In the garage
 
TIPPEDITOVER's Avatar
1978 CJ5 
 
Join Date: Jun 2011
Location: Puyallup
Posts: 2,065
Check engine light ever flash on when you initially turn the key ON before cranking? If no, then ECM not getting power. Pin 3 should have power all the time. If no power, then fuse or open wire.



Another schematic specifically for 95' Wrangler. Muddier to read. Same as above.


"Societies that lose the cohesion needed for concerted, collective action collapse, either by failing to meet an external threat or from internal conflicts."


Shaun

1978 CJ5 Wheeler
1997 Grand Cherokee Laredo 4.0 all stock daily driver - SOLD
TIPPEDITOVER is offline  
post #4 of 12 Old 07-15-2015, 03:32 PM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
Here is what I know. Pin 3 is "hot" at steady state, ignition off....With ignition on pin 9 is "hot"..... also With ignition on pin 51 is "hot" (ASD Relay control)

i cant get # 32 to register anything, its dead. Its the MIL wire and it should be giving some kind of voltage??

chucker

81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
post #5 of 12 Old 07-15-2015, 05:52 PM
TIPPEDITOVER
In the garage
 
TIPPEDITOVER's Avatar
1978 CJ5 
 
Join Date: Jun 2011
Location: Puyallup
Posts: 2,065
Ok, that's good info. Interesting. Pin 32 should have power when key is on (I think). ECM provides ground to work the light (I think-not the other way around). Bulb is missing, no good or open wiring. If that doesn't help, here is info on the bad capacitors Mike mentioned.

http://www.jeepforum.com/forum/f12/c...rs-ecu-492597/

It's not a dead CPS because you would still get fuel pump prime if that's all it was. You're not getting prime, so CPS is out.

"Societies that lose the cohesion needed for concerted, collective action collapse, either by failing to meet an external threat or from internal conflicts."


Shaun

1978 CJ5 Wheeler
1997 Grand Cherokee Laredo 4.0 all stock daily driver - SOLD
TIPPEDITOVER is offline  
post #6 of 12 Old 07-15-2015, 05:56 PM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
No shaun, the mil is not hooked up. its being a cj7 and originality on the dash was my goal. i just scan it when it runs bad, but i agree it should be throwin codes?

i think my pcm is bad ?

chuck

81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
post #7 of 12 Old 07-15-2015, 06:00 PM
TIPPEDITOVER
In the garage
 
TIPPEDITOVER's Avatar
1978 CJ5 
 
Join Date: Jun 2011
Location: Puyallup
Posts: 2,065
It's looking like it could be bad.

"Societies that lose the cohesion needed for concerted, collective action collapse, either by failing to meet an external threat or from internal conflicts."


Shaun

1978 CJ5 Wheeler
1997 Grand Cherokee Laredo 4.0 all stock daily driver - SOLD
TIPPEDITOVER is offline  
post #8 of 12 Old 07-16-2015, 04:49 AM
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant
Posts: 18,089
Quote:
Originally Posted by chucker2 View Post
No shaun, the mil is not hooked up. its being a cj7 and originality on the dash was my goal. i just scan it when it runs bad, but i agree it should be throwin codes?

i think my pcm is bad ?

chuck
At least those pcm's are a cheap and easy rebuild. Having a mil light helps diagnose things though, you could even have one tucked up under the dash.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline  
post #9 of 12 Old 07-16-2015, 05:36 PM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
Well I put in my new ( rebuilt )Pcm and still no start. Won't even crank. Fuel pump charged, then it tripped the ASD. My clock stopped, then started in a few minutes.

Maybe a short in the ignition switch?

I'm just like a dealer mechanic now!! PARTS CHANGER!!

Chuck

81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
post #10 of 12 Old 07-16-2015, 07:16 PM
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant
Posts: 18,089
You sure could be describing a bad connection on a main battery cable. I think I would clean them not forgetting cables have 2 ends.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline  
post #11 of 12 Old 07-16-2015, 07:26 PM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
ok mike, I will check contacts, then fuel, spark, etc. Basics....

81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
post #12 of 12 Old 07-18-2015, 06:16 PM Thread Starter
chucker2
Registered User
1981 CJ7 
 
Join Date: Oct 2013
Location: asheville
Posts: 141
Well I finally changed the starter and that was it after I put a new brain, Pcm.

And tightened the hell out of all the cables Good contact.

Chuck

81 CJ7 Renegade, Mocha Brown Metallic and Tan, 4.0L w/ T-5, RE 2.5 Lift, 31 BFG's on Wagon Wheels
chucker2 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome