Got the TBI installed, but have ignition questions - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Got the TBI installed, but have ignition questions

~Artec JK 1 TON SWAP~Yukon Ultimate 35 axle kit for c/clip axles with Yukon ZipThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 07-07-2010, 05:41 PM   #1
Hillbillyd
Registered User
1980 CJ5 
 
Join Date: Mar 2004
Posts: 118
Got the TBI installed, but have ignition questions

Got the Affordable Fuel Injection kit installed over the weekend, everything went great. Jeep starts and runs down the road fine, but seems to miss at idle. It did this with the carb setup too, I just always kinda blamed the carb. The ECM doesn't have any codes, and check engine light stays off, so that's why I suspect ignition. I haven't upgraded the ignition, all stock stuff. It does have new plugs, wires, cap, and rotor though. But while idling, the engine shakes, and is generally not smooth. Checked for vacuum leaks, timing, etc. I'm going to do the team rush upgrade on the cap, rotor, and wires, and use an e-coil. I think this will help alot, but I'd like to have a multispark cdi unit as well. I'm not sure if that will work though with the fuel injection setup? The way I understand it, the ECM controls the spark now, so is it multispark already? If not, how would I wire in a multispark cdi unit?

Hillbillyd is offline   Reply With Quote
Unread 07-08-2010, 06:35 AM   #2
BioTex
Registered User
2006 TJ Wrangler 
 
Join Date: May 2008
Location: Alpine, Tx.
Posts: 3,173
IMO, you would be way better off simply taking the upgrade in steps.

For instance:

Install the cap, rotor, wires and regap new plugs to .045".

Then get the timing set and see if the miss is still there. If so, do a compression test, and see if you perhaps have a weak cylinder.

Post back, and let us know. If you change out too many parts all at once, you open up a can of worms.
__________________
'85 CJ7, BDS 4" lift, 1" Body lift, 33x12.5, Shrockworks Sliders, 304 V8 with RV cam., T-176, D300, Dana 30, AMC 20.
1986 CJ10-A SD-33 Diesel/727/np208
1971 800B with 345/T-19
06' TJ Rubicon, 4" R.C. springs, BFG/AT 35s M.C. 6" fenders, rockers and surrounds, Currie front & rear adj. tracbars, tattons DC rear shaft, adj. upper - lower CA's. Bilstein 5100's
YJ Buggy Build Current project. Stroker/FI ?
1990 MJ Comanche 4.0L AX15/np231
BioTex is offline   Reply With Quote
Unread 07-08-2010, 10:09 AM   #3
1986cj
Registered User
1986 CJ7 
 
Join Date: Dec 2007
Location: Denver Colorado
Posts: 1,873
You didn't get a dist with your kit or have not done no mods to yours?
1986cj is offline   Reply With Quote
Unread 07-08-2010, 12:09 PM   #4
CSP
Registered User
 
Join Date: Aug 2002
Location: Colorado
Posts: 11,831
I was curious about the same thing. Since the AFI kit controls spark you have to disable the mechanical and vacuum advances. Did you do that part?
CSP is offline   Reply With Quote
Unread 07-08-2010, 12:54 PM   #5
1986cj
Registered User
1986 CJ7 
 
Join Date: Dec 2007
Location: Denver Colorado
Posts: 1,873
Afi's kit for a 304 comes both ways, new mod hei for spark or not, just like Howells kit.
1986cj is offline   Reply With Quote
Unread 07-08-2010, 05:20 PM   #6
Hillbillyd
Registered User
1980 CJ5 
 
Join Date: Mar 2004
Posts: 118
Quote:
Originally Posted by 1986cj View Post
You didn't get a dist with your kit or have not done no mods to yours?
I sent them my distributor and they modified it to wire into their harness. Other than that, it's still stock.
Hillbillyd is offline   Reply With Quote
Unread 07-08-2010, 10:32 PM   #7
1986cj
Registered User
1986 CJ7 
 
Join Date: Dec 2007
Location: Denver Colorado
Posts: 1,873
Did they put a GM control module in the mod dist? was it a HEI or do you still have a duraspark dist.
1986cj is offline   Reply With Quote
Unread 07-09-2010, 05:21 AM   #8
Hillbillyd
Registered User
1980 CJ5 
 
Join Date: Mar 2004
Posts: 118
Quote:
Originally Posted by 1986cj View Post
Did they put a GM control module in the mod dist? was it a HEI or do you still have a duraspark dist.
No, it's still the stock distributor. They just changed the wiring to wire into their harness.
Hillbillyd is offline   Reply With Quote
Unread 07-09-2010, 05:23 AM   #9
Hillbillyd
Registered User
1980 CJ5 
 
Join Date: Mar 2004
Posts: 118
Quote:
Originally Posted by CSP View Post
I was curious about the same thing. Since the AFI kit controls spark you have to disable the mechanical and vacuum advances. Did you do that part?
I just left the vacuum unhooked to it.
Hillbillyd is offline   Reply With Quote
Unread 07-09-2010, 08:09 AM   #10
CSP
Registered User
 
Join Date: Aug 2002
Location: Colorado
Posts: 11,831
What about the mechanical advance? I would assume that they disabled that along with wiring mods (which amount to adding a plug to the wires that were already there).

Have you been in contact with AFI yet?

You can add a multiple discharge cdi to your setup, but I wouldn't expect it to solve a drivability issue.
CSP is offline   Reply With Quote
Unread 07-09-2010, 08:33 AM   #11
Hillbillyd
Registered User
1980 CJ5 
 
Join Date: Mar 2004
Posts: 118
I actually have sent AFI an email, but they haven't responded yet. I'll call them later.
Hillbillyd is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.