Is this is a good deal? 1983 Jeep CJ7 - Page 6 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #76 of 81 Old 11-09-2012, 04:01 PM Thread Starter
matthewleeblair
Registered User
1983 CJ7 
 
Join Date: Oct 2012
Location: Anniston
Posts: 282
.

matthewleeblair is offline  
Sponsored Links
Advertisement
 
post #77 of 81 Old 11-10-2012, 11:46 AM
Ken4444
Corripe Cervisiam
 
Ken4444's Avatar
1985 CJ7 
 
Join Date: Oct 2005
Posts: 6,151
Quote:
Originally Posted by matthewleeblair
... the blinkers do not work. I guess I'll have to track down the fuse and check that...!
a very, very common problem. you may need to perform work in many areas, but in my experience you should do the following...

change bulbs

replace blinker module (relay)

clean bulb mounting bases. use sandpaper if corroded. use dielectric grease if needed.

the brake light and turn signal light housings have connectors just downstream from them. pull those apart and remove corrosuon.

replace fuses

my fuse block had light corrosion. i used an old fuse and worked it in and out to grind it off. i may have used electrical contact cleaner on it w battery disconnected. or use dielectric grease to pick up the debris and wipe it away.

"I give you a republic, if you can keep it." - Benjamin Franklin
Ken4444 is offline  
post #78 of 81 Old 11-10-2012, 03:02 PM Thread Starter
matthewleeblair
Registered User
1983 CJ7 
 
Join Date: Oct 2012
Location: Anniston
Posts: 282
Well... I was just looking at things under the dash today, before I read your reply, and after fooling around down there (didn't change anything out, just checked some connections) the blinkers work haha. Who knows?

Thanks for the tips though!
matthewleeblair is offline  
post #79 of 81 Old 11-10-2012, 03:52 PM
Ken4444
Corripe Cervisiam
 
Ken4444's Avatar
1985 CJ7 
 
Join Date: Oct 2005
Posts: 6,151
Quote:
Originally Posted by matthewleeblair View Post
Well... I was just looking at things under the dash today, before I read your reply, and after fooling around down there (didn't change anything out, just checked some connections) the blinkers work haha. Who knows?

Thanks for the tips though!
Glad it's working! Be prepared for it to stop working at any time until you find the problem.

"I give you a republic, if you can keep it." - Benjamin Franklin
Ken4444 is offline  
post #80 of 81 Old 11-13-2012, 06:04 PM
papa355
Registered User
1977 CJ7 
 
Join Date: Jan 2011
Location: warsaw
Posts: 914
blinker fluid low ?





1977 CJ7, 360 AMC with HEI, TH400 quadratrac, dana30, AMC20, SOA, 35" M/T MTZ
papa355 is offline  
post #81 of 81 Old 11-13-2012, 09:47 PM Thread Starter
matthewleeblair
Registered User
1983 CJ7 
 
Join Date: Oct 2012
Location: Anniston
Posts: 282
Hahaha... I knew I was forgetting something lol.
matthewleeblair is offline  
Reply

Tags
cj7

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome