Fuel issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 04-21-2013, 01:02 PM Thread Starter
henrydale79
Registered User
 
Join Date: Oct 2012
Posts: 7
Fuel issue

I have a 73 cj5 with the 304. Just changed the fuel pump and can't get it to work. I can siphon on the line above the pump and get gas but when I put the filter back on and try to start it I don't get any fuel. Thanks for any help

henrydale79 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-21-2013, 01:50 PM
stretch66dog
Registered User
1969 CJ5 
 
Join Date: Mar 2013
Posts: 26
Fuel issue

I know that this may sound funny. But, is the fuel going through the filter correctly?
stretch66dog is offline  
post #3 of 4 Old 04-21-2013, 02:06 PM Thread Starter
henrydale79
Registered User
 
Join Date: Oct 2012
Posts: 7
Yes the flow is correct. I bought a handful of the cheap clear one from the parts store. That way I can change the pretty regular. It's been sitting for about a year now
henrydale79 is offline  
post #4 of 4 Old 04-21-2013, 02:33 PM
stretch66dog
Registered User
1969 CJ5 
 
Join Date: Mar 2013
Posts: 26
Fuel Filter?

Is there a filter inside your carburetor. It might be that your not getting enough pressure from the pump to your carb. Check to see if it has a filter inside the carb.
stretch66dog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome