front hub stays locked - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > front hub stays locked

End of Summer Sale, 20% OFF!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 07-27-2013, 06:25 PM   #1
Bigun
Registered User
 
Join Date: Jun 2010
Location: Ball Ground, Ga
Posts: 58
front hub stays locked

1980 cj5 w/ dana 30 front and the driverside hub stays locked constantly, noticed this after seeing both axles turning w/ tc in 2H, jacked it up and locked w/ hub not locked and noticed no resistance on trying to lock or unlock hub, now don't know proper names so bear with me, when taking hub cover off the first gear on the spindle is smooth on one end with straight cut gears on other and should be held on the spindle by a small lock ring but the gear seams to slip right over the lock ring, is this my problem? and if so which one to replace? thanks for any help

Bigun is offline   Reply With Quote
Unread 07-27-2013, 08:06 PM   #2
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert Palmdale Ca. U.S.A.
Posts: 4,823
I would just replace BOTH of those 33 year old hubs.
LG
LumpyGrits is offline   Reply With Quote
Unread 07-28-2013, 05:06 AM   #3
thompsoj22
Registered User
1984 CJ7 
 
Join Date: Aug 2011
Location: ridgecrest, ca
Posts: 320
is there routine maint on the locking hubs?

Quote:
Originally Posted by LumpyGrits View Post
I would just replace BOTH of those 33 year old hubs.
LG
is there scheduled maint on the locking hubs?
thompsoj22 is offline   Reply With Quote
Unread 07-28-2013, 05:25 AM   #4
skizriz
Web Wheeler
 
skizriz's Avatar
1978 CJ7 
 
Join Date: Jun 2011
Location: , Pa
Posts: 3,579
Just clean them inside and lightly lubricate them as needed.

Sent from my HTC One SV using JeepForum
__________________
78 CJ7 258 TH400/Dana18 SOA/stock YJ springs 35" General Grabbers.
skizriz is offline   Reply With Quote
Unread 07-28-2013, 06:36 AM   #5
Bigun
Registered User
 
Join Date: Jun 2010
Location: Ball Ground, Ga
Posts: 58
everythings been cleaned, greased, w/ new bearings and races, would new Warn locking hubs fix my problem?
Bigun is offline   Reply With Quote
Unread 07-28-2013, 06:42 AM   #6
Patter
Registered User
1981 CJ5 
 
Join Date: Jul 2008
Location: Nashville, Tn.
Posts: 261
D30 shaft should look like this.



image-708497686.jpg

Not sure what you meant by smooth?

Hub should be behind snap ring. Should not slip over it.



image-590804322.jpg

Hope these phone pics work.

Sent from my iPhone using JeepForum
__________________
"I have a very strict gun control policy: if there's a gun around, I want to be in control of it."
Patter is offline   Reply With Quote
Unread 07-28-2013, 07:24 AM   #7
jeepwhore
Hair puller xtraordinaire
 
jeepwhore's Avatar
1984 CJ7 
 
Join Date: Jun 2006
Location: Kamloops, BC
Posts: 3,072
Quote:
Originally Posted by Bigun View Post
everythings been cleaned, greased, w/ new bearings and races, would new Warn locking hubs fix my problem?
How much grease did you put in the hub? It should only get a light coating, too much and it can cause problems.
__________________
'84 CJ-7: Yota axles (spartan locked front, e-locked rear) 4" BDS, 1" Daystar & 3/8" shackle lifts, 35" X-Terrains on steelies, YJ Tub & family roll bar, heater blower upgrade, 4.2L w/MC2100 & Team Rush, Warn 8274. Rebuilt 4.2/4.0 hybrid, AX15 and twin sticks/clocking ring waiting to go in.

The advertised position for a topless, dirty jeep girl has been filled......by my wife. Thanks to all that applied.
<------------and yes, that is her.
:-D
jeepwhore is offline   Reply With Quote
Unread 07-28-2013, 10:23 AM   #8
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert Palmdale Ca. U.S.A.
Posts: 4,823
OP, there is no way anyone can answer your second question since none of us know what your hub/spindle area are looks like except you.
Do you have a Factory Service Manual(FSM)and I don't mean a Haynes' etc.
Can you post pictures.
IF, your splines etc do not look like what you see in Patter's post, you may have some issues.
LG
LumpyGrits is offline   Reply With Quote
Unread 07-28-2013, 10:25 AM   #9
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert Palmdale Ca. U.S.A.
Posts: 4,823
Quote:
Originally Posted by thompsoj22 View Post
is there scheduled maint on the locking hubs?
Did you ever get the FSM?
That tells you to service the hubs when the wheel bearings & spindle bearing are serviced.
LG
LumpyGrits is offline   Reply With Quote
Unread 07-28-2013, 11:48 AM   #10
Bigun
Registered User
 
Join Date: Jun 2010
Location: Ball Ground, Ga
Posts: 58
everything has been serviced cause I rebuilt this CJ from the ground up and according to the Haynes book cause thats all I got the hub shaft is sliding past the retaining ring, is that keeping my hub locked? if so and not ever dealt with Warn hubs, will Warn hubs fix my problem or is something else wore out? thanks
Bigun is offline   Reply With Quote
Unread 07-28-2013, 11:51 AM   #11
ctorj
Registered User
1977 CJ7 
 
Join Date: Sep 2012
Location: Prineville, Oregon
Posts: 76
What hubs do you have? Is it the Factory 6 bolt hub? I had this same issue with the factory locking hubs and ended up taking them off to find that someone turned them the wrong way and the plastic Nut inside came off. Its the plastic nut that threads onto the switch part that you turn.
ctorj is offline   Reply With Quote
Unread 07-28-2013, 11:54 AM   #12
Bigun
Registered User
 
Join Date: Jun 2010
Location: Ball Ground, Ga
Posts: 58
yeah
Bigun is offline   Reply With Quote
Unread 07-28-2013, 12:03 PM   #13
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert Palmdale Ca. U.S.A.
Posts: 4,823
After 33+ years of use. You want Warn to warrantee your hubs, REALLY.
Confirm you do have the snap ring on the axle stub.
These are the black painted OEM hubs, correct??
Those Warns are junk. Look at Mile Marker, MUCH better than anyone else.
Can you post pictures for us folks to see, what you are talking about???
LG
LumpyGrits is offline   Reply With Quote
Unread 07-28-2013, 12:25 PM   #14
lukenicwalker
Registered User
1982 CJ7 
 
Join Date: Jun 2012
Posts: 156
Quote:
Originally Posted by LumpyGrits
After 33+ years of use. You want Warn to warrantee your hubs, REALLY.
Confirm you do have the snap ring on the axle stub.
These are the black painted OEM hubs, correct??
Those Warns are junk. Look at Mile Marker, MUCH better than anyone else.
Can you post pictures for us folks to see, what you are talking about???
LG
LG - I think his question was would replacing his existing hubs with new Warn hubs fix his problem, not whether or not Warn would warranty his 33 year old hubs.

OP - photos would certainly help, and I agree with LG on going with Mile Marker. They seem to be a bit higher quality...
__________________
ldw
lukenicwalker is offline   Reply With Quote
Unread 07-28-2013, 12:29 PM   #15
Bigun
Registered User
 
Join Date: Jun 2010
Location: Ball Ground, Ga
Posts: 58
have not said anything about a warranty, yes they are the factory hubs, no I'm not able to post pics
Bigun is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.