engine fault, dying when I push gas pedal.. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 05-29-2003, 10:29 AM Thread Starter
Popol
Registered User
 
Popol's Avatar
 
Join Date: May 2003
Location: Ibiza, SpaIN
Posts: 106
engine fault, dying when I push gas pedal..

Hello all.

This is more of an annoyance, but still id like to get it fixed.

The car is a 79 cj7 5.0 V8 auto, when I press the gas pedal hard, either from standstill or when moving at any speed, the engine stalls for a few seconds, then spurts into life...

If i just push the gas pedal about 20% of max travel the car works fine, but if i floor it the car stalls almost, (best way to describe it) if i keep my foot down and leave it there, then after a few seconds it starts to pickup and seems to gain momentum..

I am guessing its a blocked/dirty carburetor? but I am not sure, open to suggestions....

Popol is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-29-2003, 01:09 PM
mad_matt
Registered User
 
Join Date: Apr 2003
Location: Zanesville, Ohio
Posts: 34
How big a carb ya runnin? 5.0, as in ford? Does it do this at low rpm or also runnin down the interstate at 55 when you give er gas? Yer vaccume advance might be pinched causing the hesitation. Also might be a miss from things like bad spark pluggs or a dirty distributor. Dunno. But they would be a good place to start lookin.

'76 cj-7 on 35's
"What the hell do you mean they don't make banjo bolts anymore?!"
http://www.jeepaholics.com/rides/view.asp?id=681
mad_matt is offline  
post #3 of 5 Old 05-29-2003, 02:11 PM Thread Starter
Popol
Registered User
 
Popol's Avatar
 
Join Date: May 2003
Location: Ibiza, SpaIN
Posts: 106
as to carb I must admit I havent had a chance to look yet been busy patching the car so the lights and stuff work, now getting around to looking more closely at the other faults.

5.0 as in Litres, I am not sure on the american sizes (im in spain) I guess that is 304 ?

It chokes with the pedal down from standing, and when driving at about 60 kph..

If i press my foot to a third of its travel, its finme and pulls ok, if i floor it my head shoots forward as the car literally takes a dive and then it starts to pickup the gas after about 3 or 4 seconds if i leave my foot down, if i take my foot straight off and reaplly again its fine to about a 3rd of its travel..
Popol is offline  
post #4 of 5 Old 05-29-2003, 02:20 PM
OldJeepguy
Registered User
 
OldJeepguy's Avatar
1979 CJ7 
 
Join Date: Dec 2001
Location: Santee, CA.
Posts: 753
Sounds like the accelerator pump is bad - try to find a rebuild kit for the MC 2100 carb and it will cure the problem - it comes with a new power valve as well.

Last edited by OldJeepguy; 05-29-2003 at 02:45 PM.
OldJeepguy is offline  
post #5 of 5 Old 05-29-2003, 04:03 PM
possum398
Registered User
 
Join Date: May 2003
Location: Mississippi
Posts: 22
Carb?

I have that same problem. My is caused by my carb. I have a 2bbl 500 cfm Holley. It is a good carb for the application, but mine is in need of a rebuild.
possum398 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
engine trouble, water in oil, and dying CopenhageCowboy Jeep CJ Forum 4 11-01-2009 06:54 PM
push rod and rocker jeepcj304 Jeep CJ Forum 9 03-04-2008 06:01 AM
Is my engine dying???? webejpn01 Jeep CJ Forum 10 01-15-2007 10:47 AM
First dying engine post this week... 143hc Jeep CJ Forum 8 11-20-2005 04:51 AM
258 engine bent push rod dtrimble Jeep CJ Forum 5 07-15-2004 06:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome