electrical problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > electrical problem

Poison spyder items @ oconee off road 706 534 9955Ruffstuff Axle Simple Swap Kit!The Ruffstuff NOT Universal 4 Link Kit!

Reply
Unread 05-31-2004, 09:39 AM   #1
v75vette
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2003
Location: Oxford, Ohio
Posts: 25
electrical problem

I've got an 85 CJ7 with a 6cyl. the only real mod we've done to it is the blower moter upgrade. I was going down the road one morning had my lights on and turned the blower on and it started to sputter and die, turned the blower off and it ran fine. Regularly it runs at about 14 amps, when you turn the lights on it drops to 13. the problem comes when you turn the lights on and then go to turn the heater on. As you do this the amps drop to about 10 and then climb back up to 11. I can have both on at a stop light or something and it will want to stall as i go. Any suggestions on how to fix this?

v75vette is offline   Reply With Quote
Unread 05-31-2004, 11:39 AM   #2
slickwillie
Registered User
 
Join Date: Aug 2003
Location: Albany, OR
Posts: 315
First thing I would look at would be grounds. Make sure they're all clean & tight, if that doesn't work, start tracing wires to see if you have a short somewhere. Good luck.
__________________
1983 CJ7 AMC 360, T-5, Dana 300, Dana 30, AMC 20
Warn XD9000i, RE hand throttle, 1" body lift, OBA
[URL=http://www.cascadeoffroaders.net/index.htm]Cascade Offroaders[/URL]
slickwillie is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.