Electrical problem???? - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 10-10-2006, 08:57 PM Thread Starter
Registered User
Join Date: Apr 2006
Posts: 28
Electrical problem????

Hello...just noticed today my oil pressure gauge, RPM gauge, and lights in my dash quit working. Checked all the fuses and seems to be okay. Everything else electrical still works????? Any suggestions on where to look or recheck??? Thanks in advance!

1979 CJ7

mattmosman is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
electrical problem idaho elk Jeep CJ Forum 1 05-03-2008 09:58 PM
CJ7 Electrical Problem mcdaddytx Jeep CJ Forum 9 01-02-2006 06:18 AM
Electrical Problem pf1130 Jeep CJ Forum 23 12-01-2005 04:32 PM
Another CJ 7 Electrical Problem nozzleram Jeep CJ Forum 10 02-05-2005 08:29 PM
electrical problem v75vette Jeep CJ Forum 1 05-31-2004 11:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome