Cold engine runs ruff untill choke opens - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 01-21-2010, 02:17 PM Thread Starter
Lgleason
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2010
Location: Sonora
Posts: 54
Cold engine runs ruff untill choke opens

When the engine(4.2L) with stock carb is cold and the choke sets to the closed position the engine runs very rough and almost dies if driven before it warms up enough to open the choke. This seems just the opposite of what it should be doing. I'm thinking of a new carb but this just doesn't sound like that's the problem. Any ideas?


Last edited by Lgleason; 01-21-2010 at 03:40 PM.
Lgleason is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-21-2010, 03:46 PM
dangjeep
Registered User
1984 CJ7 
 
Join Date: Apr 2008
Location: Maricopa
Posts: 116
This was happening to me recently, I found that my choke was closing too much and not letting in enough air. So I backed it off a little more and now is all good.

dang

84 CJ7-258-T5-D300-4.10 gears 33" tires Nutter Bypassed Team Rushed
dangjeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
304 + Holley 470 CFM TA, electric choke - Cold starts suck PhatBasturd Jeep CJ Forum 36 05-29-2010 02:21 PM
Engine still runs...still won't shut off SQF1 Jeep CJ Forum 4 04-20-2009 06:56 AM
1985 cj runs bad when cold? brn2drl Jeep CJ Forum 13 03-04-2008 09:16 PM
hard cold starts, runs bad cj7renegade Jeep CJ Forum 2 01-16-2007 10:43 PM
New Engine Runs!! But I have 2 questions. jadams68 Jeep CJ Forum 13 07-08-2005 12:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome