post #1 of Old 01-30-2013, 12:54 PM Thread Starter
sanmiam
Registered User
 
sanmiam's Avatar
1983 CJ7 
 
Join Date: Oct 2005
Location: Philadelphia
Posts: 259
Clutch will not disengage :mad:

So I FINALLY have everything together (5 years in the making). Start the engine up, try to put it in gear and cruch, the sounds of gear cruntching.

I cannot for the life of me figure out why. with the engien off and the Jeep in gear: I depress the clutch pedal and the thing will roll like in neutral. I release the clutch pedal and it catches like it is in gear.

Suggestions on what I may have screwed up?


Building a Jeep is like playing golf, every now and then you get a good shot that makes you believe, hey I can do this!
sanmiam is offline  
post #2 of Old 01-30-2013, 01:16 PM Thread Starter
sanmiam
Registered User
 
sanmiam's Avatar
1983 CJ7 
 
Join Date: Oct 2005
Location: Philadelphia
Posts: 259
Forgot to add - 360 mated to a JEEP T18 (clutch fork is already notched)

Building a Jeep is like playing golf, every now and then you get a good shot that makes you believe, hey I can do this!
sanmiam is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome