cj7 over heating ????? or funky guage - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > cj7 over heating ????? or funky guage

Nitro Gear Packages Now Available at Rockridge 4wdGear Packages Available! Your # 1 Diff Shop is ROCKRIDGE 4SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!

Reply
Unread 05-24-2003, 12:27 PM   #1
maestro
Registered User
 
Join Date: Feb 2003
Location: winchester, ma
Posts: 17
cj7 over heating ????? or funky guage



85 cj7 with 258 and fuel injection+borla header

first of all i gotta mention my whole dash has a short or a bad ground...

until recently my only problems have been a dancing voltmeter

but now my temp guage within the last few days has been saying that the engine is running too hot. there are no visiable signs that it is over heating, no smoke, or loss of radiator fluid but it keeps going from fine to redline while i drive

im wondering how possible its just the guage going nuts or could it be that i need a new water pump anyone got any ideas

im gunna throw in a new guage this afternoon and see what happens

any other opinions would be helpful

__________________
1985 jeep cj7,258 with mopar MPI, borla header, custom flowmaster exhaust, 1.5 inch body lift, 3.5 inche suspension lift 31inch tires,mean green alternator
maestro is offline   Reply With Quote
Unread 05-24-2003, 12:38 PM   #2
rok_toy
Registered User
 
Join Date: Feb 2003
Location: CA
Posts: 59
Header!!!

I went through the same problem. I checked the temp in the radiator, with a meat thermometer. It said I was at 170 degrees, about normal. The guage was reading almost at the hot end of the spectrum.

What I found is the heat coming off the header was heating up the sending unit. Try puting some type of heat shield between the sending unit and header.



Let me know how it goes.
__________________
1986 CJ-7, 258/T5/Dana300, Dana 44's, 4.89's, ARB's, SOA, Warn8K, high-steer, 37" MTR's, onboard air( york style)...more to come!!
rok_toy is offline   Reply With Quote
Unread 05-26-2003, 07:23 AM   #3
maestro
Registered User
 
Join Date: Feb 2003
Location: winchester, ma
Posts: 17
tried putting in a new temp guage but the damn thing didnt fit, ended up being a bad ground on the dashboard i dunno how that effects the temp guage.

thanks for the suggestion though ill keep it in mind if i have any future probs.

THANKS!!!
__________________
1985 jeep cj7,258 with mopar MPI, borla header, custom flowmaster exhaust, 1.5 inch body lift, 3.5 inche suspension lift 31inch tires,mean green alternator
maestro is offline   Reply With Quote
Unread 05-27-2003, 02:58 AM   #4
Popol
Registered User
 
Join Date: May 2003
Location: Ibiza, SpaIN
Posts: 106
I still have this problem I live in a hot climate anyway, so the first thing i did was to take out the thermostat as a precautionary measure. The temperature gauge still says the same, goes to over off the scale in no time at all.

Process of elimination tells me that the engine temperature is now ok, (I measured it also using a meat thermometer, its within limits), so either the gauge is faulty or the temperature sender is faulty, next is to change the temperature sender and see if that clears the problem, if it doesnt then ill change the gauge..
Popol is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.