CJ7 engine will turnover but not start - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > CJ7 engine will turnover but not start

XJ Rail Sale!The Ruffstuff NOT Universal 4 Link Kit!Vanco Big Brake Kit Promotion!

Reply
Unread 06-20-2013, 10:09 PM   #31
jguess1
Registered User
 
Join Date: Sep 2012
Posts: 21
They looked burnt and black.

jguess1 is offline   Reply With Quote Quick reply to this message
Unread 06-20-2013, 10:27 PM   #32
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert Palmdale Ca. U.S.A.
Posts: 5,181
Rich!
LumpyGrits is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 01:34 AM   #33
BagusJeep
Web Wheeler
 
BagusJeep's Avatar
1981 CJ7 
 
Join Date: Jul 2009
Location: Bali, Indonesia
Posts: 4,630
jguess,

Sounds like you are jumping arund a bit there from one symptom to another without being methodical and ruling something out.

Fuel

Ok, you now know the fuel pump works

But you are not getting fuel into the engine.

That only leaves the carb. You are going to have verify this is the problem and take it apart. A common issue is the float bowl and the inlet valve. A piece of dirt can lodge in the inlet or the float be set too low.

Spark
Those platinum plugs may not be good. Ordinary plugs work best, nothing fancy. You need to gap them correctly and check you have a regular bright crisp blue spark. If tey are gapped and you do not it is because your coil is not deenergising properly. Have a look at the voltage at the coil and whether the engine is properly grounded.
__________________
BagusJeep lives in Bali, the Land of Temples.
With a Jeep every prayer counts.

1981 CJ7 258ci - Bagusjeep
1984 CJ7 258ci - Puthijeep
1981 J20 258ci - Gladys
1995 Cherokee 4.0 - CHEROKEE
BagusJeep is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 11:31 AM   #34
jguess1
Registered User
 
Join Date: Sep 2012
Posts: 21
Thank you all for your help. I am very new this and have enjoyed working on the jeep. As for the spark plugs they are gapped correctly but did not have a blue spark. I am not sure how to start on either one of the recommendation you had for the carb or volt check. Do you know of a good step by step explanation out there?
jguess1 is offline   Reply With Quote Quick reply to this message
Unread 07-03-2013, 06:32 AM   #35
jguess1
Registered User
 
Join Date: Sep 2012
Posts: 21
The float bowl was the problem. I have got the engine running again. However, when the engine is cold I have to spray carb cleaner in the carb to start the engine. After it warms up I do not have any problems. Do you all have any recommendation?
jguess1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.