CJ7 Ditto, need help with keeping this kid running after a good start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 09-10-2012, 10:42 PM Thread Starter
madmoto375
Registered User
1982 CJ7 
 
Join Date: Jul 2012
Location: Panama City
Posts: 10
CJ7 Ditto, need help with keeping this kid running after a good start

OK, I have an 82 cj7 Renegade with the 4.2L 258 L6 130K miles on her. I just bought her after a frame-off restoration done by the po. She's a beauty and was running outstanding for about a week and nothing but trouble since.I got my grape rattled over in Iraq and Afghanistan, so memory and focus is not my forte, so please bear with me. The engine has a holley 2300 2 bbl 390 cfm carb on it that was taken off today and inspected and cleaned before being reassembled and installed. I have put a new ignition control module and starter coil, I have also installed new under the hood steel braid fuel lines with a see through filter.She's got hedmen headers no cats, just mufflers. The engine starts but then dies out anywhere from a couple of seconds to 20 seconds. But it dies like someone cut the switch off; voila, no fuel. I can see this is happening but don't know what to do about it. I've been trying to fix this for a couple of weeks now and I don't care how or who I get help from. Could it be the sending unit fr0om the tank, bad gas, the float in the carb bowl? I'm all ears, eyes and ready to get this jeep on the road before summer is completely gone.

madmoto375 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-10-2012, 10:52 PM
BagusJeep
Registered User
1981 CJ7 
 
Join Date: Jul 2009
Location: Bali
Posts: 5,280
Have you got air in the fuel? You can see this at the see through filter. If so the flexible hose at the tank has split, drop the tank in 20 minutes and have a look, renew as necessary. Rarely it is a split Tube so have a good look at the entire fuel line for damp patches. Possibly even a pinched flexible hose near the tank.

The tank and fuel lines are very simple but you need to be careful about old age perishing the rubber parts and rust and debris blocking the sock filter in the tank. US market has other gubbins hanging off the tank but it will possibly be the fuel line between the sender unit and the fuel pump.

You don;t say what fuel pump you have fitted. The mechanical ones are reliable but eventually split thgeir diaphragms and leak fuel out of the bottom. Electric ones are prone to electrical issues and you need to check they have voltage.

If not fuel then my first guess would be ignition, low voltage side. This is very simple to check with a test 12V lamp and long leads, best $5 tool in my tool box for checking such things. Connect one lead to the battery -ve and the other to the red with tracer wire after taking it off the coil +ve. The lamp should be bright in Start and dim in Run. Connect one lead to the battery +ve and the other to the green wire taken off the coil -ve. The lamp should blink on and off in Start.

BagusJeep lives in Bali.

1981 CJ7 258ci - Bagusjeep
1984 CJ7 258ci - Puthijeep
1981 J20 258ci - Gladys
1951 Willys CJ3A/MB/M38 - Little Willy
1995 Cherokee 4.0 - CHEROKEE
BagusJeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Starter motor keeps running after start NSC Jeep CJ Forum 3 01-25-2011 03:23 PM
'86 cj7 wont start after running out of gas lancep93 Jeep CJ Forum 10 06-28-2010 02:59 PM
258 not running good when hot ideal_trucks Jeep CJ Forum 7 06-14-2010 07:44 PM
Good Start/Hard Start/No Start tigercreek Jeep CJ Forum 2 05-25-2010 07:48 AM
rough running '89 4.0 won't start Moondance Jeep CJ Forum 1 03-14-2007 04:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome