CJ Stalling and losing power - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 07-09-2011, 07:44 AM Thread Starter
DirtyDevin
Registered User
1983 CJ7 
 
Join Date: Jul 2009
Location: Atlanta
Posts: 205
CJ Stalling and losing power

I am not sure what caused the issue but here is a little back story.

I took the CJ camping a couple of weeks ago. I wheeled it pretty good then drove about 60 miles back home all without incident. After bringing it home I took it to the local car wash and sprayed it down including the motor. I covered the carb and distributor with plastic and don't believe anything got wet.

I drove it home with no problems. I then noticed I was really low on gas so I put about 5 gallons of gas in the tank out of a red gas can I had in the garage.

While driving it the other day it was losing power under load almost like it was put in neutral. It has only been getting worse. It idles great....purrs like a kitten, but if you try to give it power and go it will take off then just loses all power like it was put in neutral, but it doesn't stall usually although sometimes it does.

I changed the fuel filter and I put a bottle of Iso Heet in the tank last night thinking there may be water in the fuel and the problem only got worse.

Any thoughts / ideas?

DirtyDevin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-09-2011, 12:25 PM
dslywalker
Registered User
1983 CJ7 
 
Join Date: Feb 2010
Location: Glendale,Arizona
Posts: 1,563
Your ignition module could be bad.
dslywalker is offline  
post #3 of 5 Old 07-09-2011, 01:00 PM
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant
Posts: 18,090
There is a $2.00 air filter on the bottom of the gas tank vent (charcoal canister) that can cause those symptoms when dirty. You got it muddy from the sounds of things. Quick test is to crack open the gas cap and drive it that way for a bit.

A blocked air filter can also cause those symptoms.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline  
post #4 of 5 Old 07-09-2011, 06:46 PM Thread Starter
DirtyDevin
Registered User
1983 CJ7 
 
Join Date: Jul 2009
Location: Atlanta
Posts: 205
I took the gas cap off and that didn't help. If anything it's getting worse. stalled in the neighborhood and had to get towed home by a JK
DirtyDevin is offline  
post #5 of 5 Old 07-09-2011, 07:12 PM
Rollbar
Registered User
1984 CJ8 
 
Join Date: Aug 2005
Location: Florida
Posts: 2,451
Change out the plugs Auto-lite Copper plus. Maybe you cracked some by getting them wet when they were hot.

Check the PCV and see if it is getting good suction.
Rollbar is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Losing Power in 5th Gear? WTF bucs1fan Jeep CJ Forum 8 09-25-2012 03:33 PM
cj losing power at 3000 rpm? jeepnkal Jeep CJ Forum 1 09-12-2009 09:19 AM
losing power 3Rotts Jeep CJ Forum 6 02-12-2007 05:00 PM
Losing power? gtrpup2 Jeep CJ Forum 1 08-12-2006 02:09 AM
Losing Break Power Todd Pope Jeep CJ Forum 5 03-31-2005 12:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome