CJ Bogs Down - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > CJ Bogs Down

Savvy FOX IFP 4" Lift Shocks in StockSavvy/Currie Aluminum Control ArmsSavvy Aluminum Gas Tank Skid

Reply
Unread 04-14-2011, 09:20 PM   #1
Agggg
Registered User
1985 CJ7 
 
Join Date: Apr 2011
Location: Fairfield, PA
Posts: 2
CJ Bogs Down

I had my 85 CJ7 (4.2 258) out today and it ran fine. I had recently replaced the water pump and fuel filter. A few times in the past bog down when going up steep hills. It ran perfect all day, but after a bumpy ride in the mountains, it started to bog down. It got really bad when I went back on the highway, going from 2nd to 3rd would feel like it was suffocating. I sprayed out the Weber carburetor, but no luck. This was probably the longest that I have ran her in months, the previous owner had rebuilt the engine and it only has 5000 miles.

Agggg is offline   Reply With Quote Quick reply to this message
Unread 04-14-2011, 09:38 PM   #2
mcmud
Web Wheeler
1983 CJ8 
 
Join Date: May 2008
Location: N.E. Alabama
Posts: 2,650
Welcome to JF.

I have a Weber, actually several. Can you identify which one(s) I have?

Reads as though you are experiencing bowl over fill, or in need of a float adjustment.. if we knew which Weber you have mounted I'm sure that sound suggestions would follow.
mcmud is offline   Reply With Quote Quick reply to this message
Unread 04-14-2011, 10:00 PM   #3
truckshop21
Registered User
1981 CJ5 
 
Join Date: Mar 2011
Location: 954, florida
Posts: 110
i bet you got a hole in and fuel line or its dryed out and cracked and sucking air
truckshop21 is offline   Reply With Quote Quick reply to this message
Unread 04-16-2011, 02:36 AM   #4
Agggg
Registered User
1985 CJ7 
 
Join Date: Apr 2011
Location: Fairfield, PA
Posts: 2
I couldn't find a model number on the carb, but I think we may have found the problem. The fuel lines do look bad, I just picked up some new hose. A friend messed with it for a while and thinks it is the vacuum advance. I am going to repair/replace that line and see what happens.

Thanks for the help.
Agggg is offline   Reply With Quote Quick reply to this message
Reply

Tags
bog , cj , fuel

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.