CJ-7 Transmission problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 11-09-2002, 10:33 AM Thread Starter
Deru Sudibyo
Registered User
1983 CJ7 
 
Join Date: Nov 2002
Location: Bogor - Indonesia
Posts: 8
Question CJ-7 Transmission problem

Hi Netters,

I am a new comer in this forum. One of my hobbies is 4x4, although I am not an offroader. I stay in Bogor, Indonesia. One of my 4x4 is CJ-7'83 wide axle. Since 8 yrs ago, its original engine (Isuzu C240 diesel) has been replaced by Toyota 13B diesel (105PS).

I am having problem on the transmission. Hard to shift and sometime can not be released. But, the funny thing is, sometime it suddenly released to neutral while running on rough surface. It is not hydrolic system, neither master nor slave piston. It must be internal transmission box. Wich part I should determine first? Please advize.

Actually I have one more question, will be post later.


Best regards,
Deru

Deru Sudibyo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transmission Problem 1982 CJ-7 stelo Jeep CJ Forum 5 05-01-2008 07:12 PM
CJ7 Transmission Problem jeepdude1107 Jeep CJ Forum 11 10-26-2006 09:01 AM
4WD - Transmission problem? Frapster Jeep CJ Forum 3 10-28-2005 04:01 PM
Transmission Problem tholmes3 Jeep CJ Forum 1 06-15-2004 04:24 PM
Transmission problem v75vette Jeep CJ Forum 4 05-03-2004 06:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome