CJ-7 stalls when braking - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > CJ-7 stalls when braking

Engo LED Flush Mount Lights *PAIR* Flood or Spot 1,600 LumYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 10-12-2008, 12:48 PM   #16
foggybottombob
Registered User
1984 CJ7 
 
Join Date: May 2008
Location: Monument Colorado
Posts: 5,830
If you have a Carter BBD. Get a rebuild kit for $30 or less and rebuild the carb. You will be glad you did. My BBD has had idle and die at stop problems for years. I rebuilt the carb and it is a new beast now.

foggybottombob is offline   Reply With Quote Quick reply to this message
Unread 10-12-2008, 01:33 PM   #17
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,581
Quote:
Originally Posted by foggybottombob View Post
If you have a Carter BBD. Get a rebuild kit for $30 or less and rebuild the carb. You will be glad you did. My BBD has had idle and die at stop problems for years. I rebuilt the carb and it is a new beast now.
You are so right, it does them wonders.

Figure it this way, every time you need plugs, you are supposed to need a carb kit according to the CJ maintenance schedule.
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote Quick reply to this message
Unread 03-21-2010, 11:35 AM   #18
lotharofthehill
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Token Creek, WI
Posts: 4
I just had the same problem in my 84 CJ7 with the 258. I just bought this CJ and it ran well after I tuned it up (cap/rotor, plugs, wires, all filters). But I thought I would seafoam it since I didn't know how well she had been taken care of and cleaned. After seafoaming, she had a really rough low idle and a hiccup when starting off from 1st. I then cleaned the carb in and out, did not remove to clean since I will be buying the32/36 soon. Still had the rough idle. Then I read Mikes post about the EGR valve. Sure enough she was a dirty bird. Took it off and cleaned with carb cleaner. Lots of junk came off the diaphram and piston. Now she idles like a champ. Thanks Mike!! My first post but sure I'll have many more. This site kicks azz.
Lothar
lotharofthehill is offline   Reply With Quote Quick reply to this message
Unread 06-08-2010, 08:04 PM   #19
slime
Registered User
1983 CJ7 
 
Join Date: May 2010
Location: Indy
Posts: 2
This old post has been very helpful to me and my "new" '83 CJ-7. It ran good but died when coming up to a stop quickly. I bought the rebuild kit for the Carter BBD. It made a huge difference. Now, when the brakes are applied I still notice the engine RPM being pulled down, the harder the brakes are applied the more the pull on the engine, but it isn't nearly as bad as it was. I think I need to keep looking at vacuum lines, etc. to really clear up that problem.
slime is offline   Reply With Quote Quick reply to this message
Unread 06-09-2010, 06:18 AM   #20
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,581
Check the intake manifold bolts also. they are notorious for coming loose causing some symptoms like that. Just cleaning the EGR valve with carb cleaner can also fix it if there is carbon in the valve.
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote Quick reply to this message
Unread 06-13-2010, 07:52 PM   #21
lotharofthehill
Registered User
1984 CJ7 
 
Join Date: Mar 2010
Location: Token Creek, WI
Posts: 4
Check all vacuum lines first. I had a crack on the one running from dizzy to T connector. Changed that and couldn't get it to kill coming to a stop. Before if I coasted to a stop no problems, but once I hit the brakes It would die.
Vacuum hose = $0.49/foot
lotharofthehill is offline   Reply With Quote Quick reply to this message
Unread 06-13-2013, 10:31 PM   #22
jaw1959
Registered User
1983 CJ7 
 
Join Date: Jun 2013
Location: Denver, CO
Posts: 3
Quote:
Originally Posted by LostINohiO View Post
ok listen:

you have clogged idle jets in your venturi...

the good news:

you can fix this yourself in 20 minutes...

u have to take the air filter off... remove the choke plate rod... remove the choke plate.... unscrew the venturi.... pull it out... try not to mess up the gasket unless u have a spare rebuild kit around...

run carb cleaner and guitar string (i used a "B" string) or piano wire through the idle jets and make sure they are clean clean clean... put it back together and viola!

no more idle problems....

many a person has replaced their carb unecessarily and complained about the BBD w/o ever getting to know a simple simple fix....

try it....

prove me right or wrong....
Ok, listen:

I tried what you describe here (though I found the information on another thread) and nothing was clogged. I did find that the two gaskets in the venturi assembly were reversed, so I corrected that, but I'm still getting the same stalling issue, and it seems to get worse as the engine warms up.

So anyway, it looks like i've proven you wrong, all these years later.
jaw1959 is offline   Reply With Quote Quick reply to this message
Unread 03-22-2014, 06:25 PM   #23
SJMixology
Registered User
1983 CJ7 
 
Join Date: Mar 2014
Location: Egg Harbor Township, New Jersey
Posts: 1
I'm finding that my '83 is stalling now when I come to a stop. Sometimes when I put it into reverse or drive after starting the engine and warming up. This is my first 258, will try all of the suggestions I've read above and let you know how it goes!
img_2014032214850.jpg

SJMixology is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.