CJ-7, 4.2L. Ran Out of Gas and Now Won't Run?!?!... - Page 3 - JeepForum.com

LinkBack Thread Tools
post #31 of 34 Old 02-04-2013, 11:43 AM
Registered User
1977 CJ7 
Join Date: Jan 2013
Location: castalia
Posts: 260
did you check all of your vacuum lines for leaks? the timing? fuel pressure? or you could have a really weird ignition module.

Only in America do you have the God given right to be loudly opinionated about something that you are completly ignorant of.
Davis77Cj is offline  
Sponsored Links
post #32 of 34 Old 02-04-2013, 12:19 PM
Web Wheeler
86cj74.2L's Avatar
2004 WJ 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 10,292
You did not answer my idle mixture screw question.
86cj74.2L is online now  
post #33 of 34 Old 02-04-2013, 08:45 PM Thread Starter
Registered User
Join Date: Aug 2006
Location: CA
Posts: 110
Originally Posted by 86cj74.2L View Post
You did not answer my idle mixture screw question.
Ok, I think I have it now!!! I took the carb off again and tore it down just to be sure. I paid particular attention to the mixture screws, ran a wire through any hole I could fine and shot carb cleaner through everything. When I put it back on I opened the mixture screws out 5 turns from closed.
It may be a bit too much fuel now and I may have to dial it back but I'm just happy it's idling. I'll need to re-time it and then I'll fine tune the mixture screws.

Thanks for all of the advice, everyone was a big help! If nothing else, I know more about this BBD carb.
dvzant is offline  
post #34 of 34 Old 02-11-2013, 11:06 PM Thread Starter
Registered User
Join Date: Aug 2006
Location: CA
Posts: 110
Update: I got the Jeep dialed in and it passed smog!!

I described my headaches to my mechanic/smog tech and he described a trick that sometimes work for him in similar circumstances.
He said to rev the engine pretty high and close the choke flap until the engine is about to die. Open the flat while still giving it gas so it revs back up quickly. That will sometimes dislodge blockages.

I figure that everyone was able to give me a lot of advice... Maybe that bit of advice with help someone else out....
dvzant is offline  

rough idle , sputtering

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome