CEL 02 Sensor Experience - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 03-11-2007, 09:48 AM Thread Starter
jeepnick
Registered User
 
Join Date: Jan 2007
Location: Utah
Posts: 97
CEL 02 Sensor Experience

I've got a '99 XJ and the CEL came on close to 60K miles. I read the code which indicated the after cat 02 sensor and reset the light. After a couple of days it came on again and I reset it. This has been going on a while. I really don't believe my sensor is bad as the majority of sensors that are replaced are still good. My Jeep doesn't exhibit any signs of rough idle, rich or lean conditions or poor fuel economy. I have the wherewith all to remove it and test it with heat and an ohm meter but if I go to that trouble I may as well replace it.

Anyone gone thru this? Is the CEL code thrown mileage related as an 02 service reminder or an actual alert to a failed 02 sensor? Is there a way to turn off the CEL other than with the code reader? If I replace the 02 with a new one and reset the CEL will my problem go away. Thanks for your input.

jeepnick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-11-2007, 09:56 AM
Carmell CJ
Registered User
 
Carmell CJ's Avatar
1978 CJ5 
 
Join Date: Nov 2006
Location: Beaumont, CA
Posts: 218
Not real sure how those things function. Might want to post this in the XJ forum for some input.

1978 CJ5, let the mods begin.
Carmell CJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
winch experience jrm72 Jeep CJ Forum 14 08-01-2009 09:15 AM
Bad experience with webercarbsdirect.com Stacydmcc Jeep CJ Forum 1 07-06-2009 01:08 PM
Anyone had experience running 33 x 13.50s on a CJ7? 84jeeper Jeep CJ Forum 0 02-17-2007 12:12 PM
Experience with custom efi jeepe Jeep CJ Forum 6 03-09-2006 03:30 PM
Anyone have experience with Zig Zag DaRaidz Jeep CJ Forum 1 02-18-2003 09:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome