carb sneezing and hard start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 08-26-2013, 09:35 AM Thread Starter
325INFREGT
Registered User
1976 CJ7 
 
Join Date: Aug 2013
Location: El Paso
Posts: 41
carb sneezing and hard start

All,

Have seen some threads on this before but am asking for a rehash. I have a 76 CJ7 with the AMC 304 and TF727 trans. It's tough to start in the morning without priming with the accelerator pedal. Additionally on the morning commute it'll sneeze from the carb (edelbrock). Is this vacuum lines? Accelerator pump diaphragm? or something else? Any help would be appreciated.

thanks in advance...

325INFREGT is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-26-2013, 09:49 AM
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert
Posts: 17,351
The hard starting sounds like a choke issue to me.

The "sneezing" could be timing.

Matt


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Matt1981CJ7 is online now  
post #3 of 5 Old 08-26-2013, 04:03 PM
james04si
Senior Member
 
james04si's Avatar
1977 CJ5 
 
Join Date: Apr 2009
Location: Arlington TX
Posts: 861
Does it only sneeze when its cold? If so that could be a lean pop and related to a choke issue as well.
james04si is offline  
post #4 of 5 Old 08-26-2013, 04:51 PM
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert - Palmdale, Ca. U.S.A.
Posts: 6,449
After warmed up. Does it start easier, run better?
X2 on choke issue with cold start.
LG

Have'n you along, is like loose'n 2 good men
LumpyGrits is offline  
post #5 of 5 Old 09-06-2013, 10:54 PM Thread Starter
325INFREGT
Registered User
1976 CJ7 
 
Join Date: Aug 2013
Location: El Paso
Posts: 41
Thanks all. Got distracted. Turns out it was the choke issue. Still isn't completely fixed but the sneezing is gone too. Appreciate the responses.
325INFREGT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome