Carb Help! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Carb Help!

Custom Axle Work at CCORRough Country Lift Kits and Parts!Swag Off Road BIG-HIT TJ-YJ Rear Bumper

Reply
Unread 03-02-2014, 05:11 PM   #1
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
Carb Help!

I have a 1980 CJ7, 258 4.2L. I haven't ran the jeep since i bought it 6 months ago. Last week, i took it out for a spin. It runs smooth until i pick up speed/rpms. Then is "bogs down" and i have no power. I suspect it was due to the fuel/air mixture in the carb. (carter carb 2bbd, stock) So today, i picked up a rebuild kit, slapped it together and reinstalled the carb. It took care of the "bogging down" issue...but now it pops, spits, and sputters when i shift gears...then it runs smooth (usually). So my question.....where do i start looking for issues. Working on carbs are fairly new to me.



UPDATE: Forgot to mention, i do NOT have the choke hooked up.

1010791_10152131345314827_388375400_n.jpg  
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-02-2014, 06:36 PM   #2
BagusJeep
Web Wheeler
 
BagusJeep's Avatar
1981 CJ7 
 
Join Date: Jul 2009
Location: Bali, Indonesia
Posts: 4,411
Is that photo taken BEFORE you rebuilt the carb?

A few things I notice:

The fuel filter is not oriented correctly. The return line shold be at 12 o'clock, yours is around 9 o'clock. this will cause problems with fuel supply.

Vacuum lines - not many in your pic. I am struggling to see the line that goes from the carb / manifold to the distributor vacuum advance. Have you got one and where is it connected to? This is an important point.

Does the accelerator pump work? Did you set the metering rods and accelerator plunger according to the service manual? Does the plunger have the ball at the bottom? Have you checked the accelerator pump is pumping? It sounds like you are momentarily running lean, which suggests no fuel is being pumped from the accelerator pump. If so this could be a linkage issue, an adjustment issue, a lack of that ball or the plunger fell apart, as mine did.

Are your idle tubes clear?

Vacuum leaks - have you checked everywhere?

Is that EGR valve connected? It is unconneed to your problem, maybe.

Ignition timing - have you set the initial advance with the vacuum unplugged at idle? What did you set it to? Are you confident the timing marks are accurate?

Ignition - have you got clean plugs? Is the cap cracked?

Just a few ideas. If you cannot adjust the idle mixture with the two air bleed screws to about 1 1/2 to 2 turns you have a problem with vacuum leaks, if you can and it shudders bad when you put your foot down I suspect the accelerator pump.
__________________
BagusJeep lives in Bali, the Land of Temples.
With a Jeep every prayer counts.

1981 CJ7 258ci - Bagusjeep
1984 CJ7 258ci - Puthijeep
1981 J20 258ci - Gladys
1995 Cherokee 4.0 - CHEROKEE
BagusJeep is offline   Reply With Quote
Unread 03-02-2014, 08:20 PM   #3
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
Hey thanks for the reply. I'll go over the stuff you listed, tomorrow. In the meantime...here are a few more pics. I'm a newbie with the jeep community. That pic was before the rebuild kit. I followed the instructions on the kit. It idles just fine and only has issues between shifting gears. For the pics...ignore the choke, as i'm just going to hook up the manual choke cable to keep things simple.
100_1689.jpg   100_1688.jpg  
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-03-2014, 04:50 AM   #4
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,152
An unhooked choke can cause issues. If unplugged electrically, it stays closed. If unhooked mechanically, it can float around closing and opening with vacuum or bounces or.... I would sure at least tie the choke open before checking anything else.
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote
Unread 03-03-2014, 05:50 AM   #5
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,126
I'm not diggin' the kink in the fuel line at the carb inlet. And you should get those hoses off of the top of the valve cover. Where does that big hose coming from the carb vent connect to on the passenger side, anyway?

It looks like you're getting quite a bit of blow-by thru your PCV intake.

I agree with John, make sure the choke plate isn't flopping around, or permanently closed.

Matt
Matt1981CJ7 is offline   Reply With Quote
Unread 03-03-2014, 07:40 AM   #6
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
THanks for the input. I should have clarified...the choke is unhooked...but the spring is still holding the choke plate from flapping open/close. As for the hoses....they were pretty bad, so i have replacements...and yes that kink didn't look good, so it was on my list of replacement parts as well. The orange/red hose leads to the valve cover on the left. Like i said before...she idles smooth...but shifting if the issue. Almost like when it goes from high RPM's to low for shifting into the next gear....thats when it spits and sputters like it's not getting the proper fuel/air.
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-03-2014, 07:54 AM   #7
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,126
So the choke is permanently in the open, or closed position?

The hose I'm questioning is the one connected to the yellow boat-shaped piece on the top of the carb. Thats the carb vent, and the hose usually connects to the vapor canister on the drivers side. Yours appears to be connected to something on the passenger side.

Matt
Matt1981CJ7 is offline   Reply With Quote
Unread 03-03-2014, 09:15 AM   #8
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
The choke plate is permanently open. The hose in question (connected to the yellow piece) runs into the top of the vale cover (i'm assuming as a vacuum line) If you look at the 2nd picture there is a black with blue stripe hose connected to the back of the carb. It just runs down about a foot and is open at the other end....almost like a drain?..no cannister that i could find. This is how the PO had is set up....and it ran 6 months ago when i put it away for the winter. I'm not saying the PO had the hoses installed correctly....i just cant seem to find a diagram to show the correct locations.
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-03-2014, 09:18 AM   #9
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
Here is a better pic to show that hose.
1012257_10152131346004827_2103745949_n.jpg

__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-03-2014, 10:12 AM   #10
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,126
Ouch....I'm afraid your PO has that thing all wrong.

1. The carb vent should either attach to a vapor canister, or vent to the atmosphere (if you don't care about the air you breath).

2. The PCV valve should connect to a manifold vacuum source, not the carb vent. There should be 2 manifold vacuum ports on the rear side of the carb. One connects to the PVC valve, the other was used for the Thermal Air Control system on the factory air cleaner.

3. Any open hoses connected to those vacuum ports will result in a major vacuum leak.

I suggest you pick up a Factory Service Manual for your CJ. It will have the proper vacuum line routing diagrams.

Matt
Matt1981CJ7 is offline   Reply With Quote
Unread 03-03-2014, 11:10 AM   #11
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
Yeah its a mess. On the rear of the carb...there is a hose connecting the 2 ports to each other (i think thats the 2 you're talking about). I have the manual...but it doesnt do much for telling me where the lines and hoses run too.
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote
Unread 03-03-2014, 03:13 PM   #12
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,126
If you have the FSM, then you should find a vacuum layout that looks something like this.

You can do without the Spark CTO and VSD valve, which will simplify things considerably. If you're not running an EGR, or the factory air cleaner, then it's even easier.

Let us know which emissions systems you have, and we can walk you thru the necessary hookups.

Matt
80_258_49_state_mt_stdcool.jpg

Matt1981CJ7 is offline   Reply With Quote
Unread 03-03-2014, 03:55 PM   #13
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,152
Tere is no spring hlding your choke plate open, it is flapping on you unless tied open, the photos even show it in different places.

This link might help you out: http://www.jeepforum.com/forum/f8/va...9/#post6872964
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline   Reply With Quote
Unread 03-03-2014, 04:08 PM   #14
Matt1981CJ7
Web Wheeler
 
Matt1981CJ7's Avatar
1981 CJ7 
 
Join Date: May 2011
Location: Elbert, CO
Posts: 10,126
Purple,

Be advised, most of the Nutter Bypass write-ups suggest you hook the distributer up to ported vacuum after the bypass is complete. Personally, I think that's a mistake. Many of us have found our engines run much better when hooked to manifold vac advance.

From the pics, it's obvious you have blow-by issues. If I were you, I'd get the PCV system hooked up properly, first.

Matt
Matt1981CJ7 is offline   Reply With Quote
Unread 03-03-2014, 08:32 PM   #15
Purplehaze1786
Registered User
1980 CJ7 
 
Join Date: Mar 2013
Location: Rimersburg, PA
Posts: 68
Thanks guys. I know the pic doesnt show a spring holding the choke open...but it is tied open on the opposite side. So the flapper is permanently open. I pissed around with it tonight...and i think i actually got it running smooth. There were a lot of hoses leading no where that i capped off. I ran all new hoses. I even changed the fuel filter and ran a new fuel intake line into the carb with less bends. I only took it around the block a few times...but it seems to run ok. Tomorrow i'll take it for a trip down the road and put a few miles on it. Keeping my fingers crossed....
__________________
My CJ doesn't leak oil, it marks its territory.
Purplehaze1786 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.