Bad Power Valve in the Motorcraft?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > Bad Power Valve in the Motorcraft??

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 04-05-2010, 09:54 PM   #1
CJ8Extreme
Registered User
1983 CJ7 
 
Join Date: Aug 2009
Location: North Carolina
Posts: 339
Bad Power Valve in the Motorcraft??

Ok, some background infor first: 1983 CJ7 with a motorcraft 2100 and Nutter Bypass. The carb has been on for about 6 months now and has always ran great no matter what. I noticed a month ago my gas mileage going down but thought nothing of it. Last weekend I began to get problems with it flooding after the jeep was hot. If I would shut the jeep off and let it sit for 15 or 20 minutes it would smell like gas and essentially flood itself while not running. This also made for a very hard start condition as well. Again this only happened after running it and getting it hot. So I kept playing with it and testing things on the jeep.

Today the issue got progressively worse and now the jeep is flooding itself at idle. I just put new jets in so I know that it should not be flooding on idle. I have black smoke out of the exhaust and a very rough idle to say the least. The float level is correct for my setup and the jets are #48. My best guess is the power valve has gone bad and now it is letting excess fuel into the intake causing an extreme rich condition, but I wanted to run this by the people here to see what they thought. I am open to suggestions on testing the problem etc. Thanks for any help!!

Oh and I have a new power valve coming in hopefully by Friday and there are no vac leaks, gas leaks etc that I have found anywhere. That was the first thing I began looking for. My timing is also right at 9 BTC as well

CJ8Extreme is offline   Reply With Quote
Unread 04-05-2010, 11:21 PM   #2
VACJ7
Hockey Rules!
 
VACJ7's Avatar
1984 CJ7 
 
Join Date: Jul 2008
Location: Northern Virginia
Posts: 3,781
Sounds like the PV. If you turn the mixture screws all the way in and seat them lightly at idle and it still runs, it's getting gas from somewhere and that is likely the PV. Could also be a stuck float needle or dirt not letting it close.
VACJ7 is offline   Reply With Quote
Unread 04-06-2010, 04:38 AM   #3
colojeepguy
Registered User
1970 CJ5 
 
Join Date: Jan 2010
Location: Colorado Springs CO
Posts: 1,065
Take the little cover off the power valve (on the bottom of the float bowl). If there's any fuel in there your pv is bad.
colojeepguy is online now   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.